New Homebridge Plug-in via MakerAPI

You’re awesome!

@dan.t I just updated the code and restarted Homebridge...I will send you PM with the requested stuff if it happens again. Thanks for taking care of us!

@dan.t I have updated as well. I noticed that my AppleTV was set to snooze after 15min. So I changed that to never. Still had sync issues but not so quickly. I am hoping the ping/pong will keep things going. Will let you know my findings.

@dan.t the newly added fan control is a bit weird. it's created a second accessory for my thermostat that I can't seem to get rid of.

I tried excluding the following attributes "speed", "switch", and "thermostatFanMode" but it always shows some form of a second accessory. In auto, with the AC running (and so, the fan) it was still showing as stopped.

This may be because my fan is always in Auto mode. Any way to remove the 2nd accessory?

Let me take a look on how to make that a bit more flexible

1 Like


The one issue I’m still faced with, if he needs a reboot I have to restart homebridge so it syncs up again...

That is hopefully fixed now in the version that was released today

1 Like

So for those of us with Apple TV’s we need to ensure at least one never shuts down or goes to sleep?

I am finding that my AppleTV gen4 running iOS beta 13.1 needs to be set to not sleep. I have been doing some testing to ensure I am not grasping at straws and blaming @dan.t for his code when more than likely it is my setup.

So the past three days since I changed the setting on my AppleTV the out of sync issues weren’t happening as often now. Since @dan.t incorporated the ping/pong not when my hub screws up and I reboot it but forget to restart homebridge massive I will see even longer days without sync issues.

Time will tell.


Completely out of sync now. :cry:

Ok so I want to contribute to solving this. What do you need from me to share with you? Logs? More logs? First born sons?

Also I have forgotten how to get the extensive logs from Homebridge for you do guidance on how to do that would be appreciated.

First but most important question: what does the HE device page show? The same state as HomeKit?

As to logging, how do you start homebridge? You didn’t configure the logging to file that I added a couple of weeks ago, correct?

The devices show the opposite of what the Home app shows. I am going to create a dashboard with the same devices I expose through MakerAPI so I can do screen shots for you.

As for logging I have homebridge running as a service on a RPi. It does do logging accordingly. I have not configured any additional logging.

This is really odd. I'm completely in sync and have not experienced the same issues. My Apple TV does sleep and it's not a problem.

I'm on tvOS 13.0 (17J5579a). I'm set for automatic updates, but might just turn them off. I just checked and version 13.0 (17J5584a) is available, but everything is running so well, I'm getting a little freaked out by your troubles :wink:

I don't have 13.1 available, but mine is not a 4K version, is yours? Before I bought mine, I did read accounts of owners with the 4K version running into HomeKit issues, but only a few posts about it, so I took it with a grain of salt.

Have you tried a new Homebridge installation on another SD card? Sorry if you already posted that. I've been on vacation and missed some replies. Looked back through the thread a bit, but didn't notice if you mentioned doing that. Some of the budget SD cards I have tried were pretty easily corrupted, and so you can get all kinds of strange behavior from read/write errors.

Can you PM me your homebridge config? I'll add the configuration parameter to enable logging and send it back to you

I don’t use SD cards on my RPi. I went down the SSD route. No issues with other stuff running on it.

And yes mine is the 4K version.

1 Like

Damn! Another wild card.

I have the 4K version but also an iPad....
I am not home but want to do a test:

Homebridge works without an iPad or Apple TV, however, you can't do automations. I want to see what happens when I turn off my Apple TV and iPad while being on my home LAN. In theory, the Home App should still work. If that is the case, we could try to unplug the Apple TV and see if that "fixes" the issue once it is out of sync. I am trying to isolate where the issue lies with this....

1 Like

Home app will not work without an iPad or AppleTV unfortunately. The iOS app will consider it not available.

I use the Home app all the time without a HomeKit hub. You just have to be on the same LAN as your Homebridge server. A HomeKit hub is only necessary for remote access (away from your LAN) and for automations (as Dan said).

1 Like