New Homebridge Plug-in via MakerAPI

The call doesn't fail now, but it sets an insane range. I set it to 67-75 and it goes to 32-70. I moved it again back to 67-75 and it jumped to 67-53. It changes about 1 second after I set it.

It seems to report OK, but then picks some arbitrary number. Now it's 64-66.

Here's the MakerAPI side of it, me calling 75 and it arbitrarily picking 71

The first one looks like a fahrenheit/celsius conversion.

The second one, with the arbitrary "71", I have seen that often with sliders in Homekit. Homekit often fires an "in between" value even if you haven't finished your sliding action. Not sure how much I can prevent this. Let me play a little bit more with that. I only use a virtual thermostat so I hope I can reproduce your issues

Can you bring in chromecast/google speaker devices into homebridge via makerapi?

Added the devices in HE but nothing coming through via homebridge.

HomeKit doesn’t really support these types of devices. HomeKit has a so called “SpeakerService” but it is meant for doorbells where you can “speak” to. You would get a “device not supported” tile if I would try to expose them.
There are 3rd party apps that work with HomeKit that could do it (e.g. Eve App), but you would still not be able to control these devices in the Home app or via siri.
Some people wrote plugins to expose speakers as a dimmer. Being able to turn it on or off and set the volume. But that has the side effect of turning on the speaker if you ask Siri to turn on the lights.

Bottom line, there is no clean way to do it until HomeKit adds a service that can be used for these types of devices.

And yes, Apple does it for the HomePod, however, they have not added that service for 3rd party integrations....

That makes sense. Ty

So I've noticed, if you do a reboot of the hub, it will cause homebridge to stop working. It's like the devices are frozen until you restart the homebridge service.

Anyway to fix this?

I never reboot Homebridge... not even after Hub updates. How long do you wait after you rebooted the hub? It could take up to 5 minutes. Do you see any error messages thrown by Homebridge?

I never timd it.

But it appears to not work correctly. I've got it due to leaving home and realizing my virtual precense switch never turned off.

I had to restart the service then it started working again.

I’ll take a look at it

@mik3 and @mbaran, I didn't forget about you two and am still working on your issues. It's just a bit crazy right now, apparently the company I work for actually expects me to do things FOR THEM to get paid.... Never heard of that concept before, must some new "Gen XYZ" kind of thing..... Stay tuned...

1 Like


I did a reboot of the hub today and had to restart the homebrisge service to get things to communicate again.

Maybe the platform you're running Homebridge on? I run mine on a MacBook Pro. Rebooting was an issue I too had before, when I was running the tonesto version of the Homebridge app, but with Dan's MakerAPI version of Homebridge, it's no longer a problem. When the hub reboots after update, everything just picks up where it left off.

I’m using Ubuntu server

Unrelated question to my previous issue, but do you know if there's a way to make a temperature sensor show the temperature on the tile?

I have a virtual temperature sensor that shows up in Home as a "Temperature Sensor" but the tile on the main screen only shows a thermometer icon. I'd love to see it actually show the temperature, like my thermostat does.

Is this really a virtual temperature sensor or a virtual thermostat? What driver are you using for this virtual device? What is listed under "Current States" in Hubitat for that device?

It’s a virtual aggregate driver that’s averaging out all my temp sensors.

The state is

  • Temperature: 76.50

Here’s how homebridge looks


I have a feeling that this device has more states than just temperature. Did you show me all states? The plugin selects the type of tile based on all states that are present at a device, so it is important for me to see what else is there.

Here is how it looks when there is just temperature as a state variable


Good catch,

This device reports Illuminance, Humidity, Motion, and Temperature. I am using "excluded_attributes" to exclude motion, illuminance, and humidity.

Do I also need to exclude the capabilities?

Ok, do me a favor, take a screenshot of the device current states and show me the part of your config where you have set the excluded parameters. This way I should be able to reproduce this

No, you can do either but don’t have to do both