New Homebridge Plug-in via MakerAPI and Eventsocket

community_app

#346

@JDogg016: No I haven't seen that. Interested in getting the answers to @Townsmcp questions though.

@aaron: Where do you not see the fan turning off? In the HE logging or the homebridge logging?


#347

This One


#348

Which driver are you using for it on the HE end? Going to see if I can replicate it


#349

Whichever driver is created by installing and using the HE iOS app for presence.


#350

Ok, thanks, going to see if I can replicate the issue. Just need to leave my house once in a bit.....


#351

I don't get to the logs in time to review once I realize the device turned off. I went ahead and ensured logging is on for all devices and Maker API. I also setup a notification to my PushOver device to notify me when a fan turns off. Hopefully I can narrow this down to what might be the issue.

I do know that when I have the HB Lights being controlled by Homekit (this was for either yours or Tonesto's) the light would randomly turn on.

Also I have the preference setting to turn the child nodes on (meaning HE creates a fan and light child device for each HB controller) and initiate all on/off/fan speeds through those children devices.

I will keep you posted on what I find.


#352

I am going to see if I can add some more logging to the plugin to help tracing this one down.


#353

@aaron
I just uploaded a new version of the plugin. You can enable some extended logging in that version. No other functional difference. In your config.json, set
"debug": true
for the plugin and restart it once.
This will enable to logging of all calls the MakerAPI. This way we can find out if it is really HomeKit that is doing it. The additional log entries look like this:

[7/5/2019, 8:30:53 AM] [Hubitat MA hhm:0.2.14] GET:  { path: '/devices/972/on', method: 'GET' } {
  id: '972',
  name: 'Virtual Switch',
  label: 'DummyButton',
  attributes: [
    {
      name: 'switch',
      currentValue: 'on',
      dataType: 'ENUM',
      values: [ 'on', 'off' ]
    }
  ],
  capabilities: [
    'Switch',
    { attributes: [ { name: 'switch', dataType: null } ] },
    'Refresh'
  ],
  commands: [ 'off', 'on', 'refresh' ]
}

In this example I am sending the "on" command to device ID 972 and it also shows the response that we got from MakerAPI.

I am not sure how you start homebridge. I am using pm2 which automatically creates a log file that we could look at once that problem happens. You might have to do something different to capture the output depending on how you start it.


#354

@dan.t Where in my config.json do I add debug:true?

"bridge": {
"name": "Homebridge",
"username": "A1:C3:B4:56:78:3D"
},
"description": "JSON API",
"platforms": [{
"platform": "Hubitat-MakerAPI",
"name": "Hubitat",
"app_url": "http://myHEhub/apps/api/2414",
"access_token": "my-access-token"
}]
}


#355
"bridge": {
"name": "Homebridge",
"username": "A1:C3:B4:56:78:3D"
},
"description": "JSON API",
"platforms": [{
"platform": "Hubitat-MakerAPI",
"name": "Hubitat",
"debug": true,
"app_url": "http://myHEhub/apps/api/2414",
"access_token": "my-access-token"
}]
}

Really anywhere within the platform config. added it above, right under the name parameter


#356

I have that added and will watch. Might take 24-36 hours. Seems that is when I notice it. Thank you!


#357

I think the issue is resolved. My apologies, I must have missed an update to the HEplugin along the way.

It seems to be reporting just fine for now.


#358

Just want to say thank you so much! Didn't even know homebridge existed until i found this thread. I was able to get everything into homekit even my nest cams in less than a day. Quickly spun up a linux box using an old desktop I had and got to work.. this is just so convenient now!!


#359

During the YouTube video tonight I started the update to 2.1.2.123 but then noticed Homebridge quit updating correctly. I could toggle a switch and it would turn on but then the icon in the Home app would turn change back to the state it was in after the update after a bit even though the switch remained on. I tried rebooting the instances of Homebridge, tried rebooting the PI, and tried rebooting the Hubitat hub. Eventually I reverted back to 2.1.2.119 until I have more time to try to figure this out. As soon as I went back to 2.1.2.119 it seems to be working correctly again. Anyone upgrade without issue?


#360

I use the HubConnect version but it's working fine as far as I can tell. I did a very short test... I opened Home on my phone and turned a light off.. waited.. then back on. I went to HubConnect server and did the same from it's device page and finally, from the hub with the real, physical switch. Every test worked.

I know it's not identical, but a lot of the code is similar... using Eventsocket, for example.


#361

@tterk1 I noticed similar. So I quit homebridge and reran it and notice in the logs that there was a new version of maker api. I updated that and noticed there was a new version of npm. Updated that too and all seems to be working fine now


#362

I believe all the plugins are up to date, and were at the time...


#363

I don’t see an issue with the latest firmware. My hub is humming along with Homebridge. Do you see any log output on Homebridge giving me any indication?


#364

Sorry I'm fairly new to Homebridge and this is the first issue I've had other than getting the commas right in the json file. Where do you look on Homebridge for logs?

Thanks.


#365

What are you running homebridge on, a raspberry pi? How are you starting homebridge, with systemd?