New Homebridge Plug-in via MakerAPI and Eventsocket


#225

I had a backup but I thought I heard they weren't useful.
I made a backup again after I finished moving everything.
Lets me re-evaluate what I'm displaying in the system anyway...


#226

Anyone have a Hampton bay fan controller and finding it doesn't update in HomeKit if the fan is turned on by an automation? I can control it through HomeKit but if my automation turns it on it still shows off.


#227

All three of mine are working without issues.


#228

Are you useing the built in driver? And are you useing the child device option?


#229

Yes to both questions.


#230

You sure you are on the latest release? There were some issues in regard to fans that were fixed, especially in releases 0.1.11 to 0.1.17...

If you are, I would need to see the output of homebridge at the time when your automation sets the fan to on to make sure that the event is getting there.


#231

I’m pretty sure I am. Just looked for outdated apps yesterday. I’ll get you that info this evening when I get home.


#232

I have noticed this recently as well, although I have the GE Smart Fan Controller. When I get back to the house, I'll capture the Homebridge logs while triggering a HomeKit scene…


#233

Here is the log of when the automation turns on the fan. Its the bedroom fan 963.

[5/9/2019, 5:02:29 PM] [Hubitat hhm:0.2.4] Change Event (Socket): (Open Weather:930) [TEMPERATURE] is 59

[5/9/2019, 5:05:17 PM] [Hubitat hhm:0.2.4] Change Event (Socket): (Bedroom Fan Fan:963) [SPEED] is medium-low

[5/9/2019, 5:05:17 PM] [Hubitat hhm:0.2.4] Change Event (Socket): (Livingroom Fan:2) [SPEED] is low

[5/9/2019, 5:05:17 PM] [Hubitat hhm:0.2.4] Change Event (Socket): (Front Bedroom Fan:99) [SPEED] is low

[5/9/2019, 5:05:18 PM] [Hubitat hhm:0.2.4] Change Event (Socket): (Front Bedroom Fan:99) [SPEED] is low


#234

And the automation turning them off.

[5/9/2019, 5:07:37 PM] [Hubitat hhm:0.2.4] Change Event (Socket): (Bedroom Fan Fan:963) [SPEED] is off

[5/9/2019, 5:07:37 PM] [Hubitat hhm:0.2.4] Change Event (Socket): (Livingroom Fan:2) [SPEED] is off

[5/9/2019, 5:07:37 PM] [Hubitat hhm:0.2.4] Change Event (Socket): (Front Bedroom Fan:99) [SPEED] is off


#235

Thanks. And on both automations you don’t see a reaction in Homekit? Interesting....


#236

Sure don’t. The other 2 fans work fine. Leviton fan controller and a Honeywell.


#237

:man_facepalming:
I bet it works if you set that fan to “low” or “medium” and not “medium-low”....

I know what it is but not near a computer at the moment. I’ll fix that ASAP...


#238

Yep that works. Guessing medium-low isn’t declared somewhere?


#239

The fan "definition" includes it, but not all physical fans actually implement everything.. such as "Auto" (or "Breeze" or whatever marketing term they choose.)

The result is the "driver" has to decide what to do. Nothing or translate it into a something else.

:slight_smile:

Did I read somehwere that Hubitat chose to translate Medium(anything) to Medium, where that needs to occur. (GE fan maybe?)


#240

All, long time no update, so here is one. Version 0.2.5 just got published. Nothing major:

  • allows usage of DNS host names instead of IP address to connect to hubitat
  • fans that support setLevel command will use setLevel instead of setSpeed to allow finer granularity of speed
  • fans support all 5 speeds defined by the FanContol capability ("low","medium-low","medium","medium-high","high")
  • code baselined with homebridge-hubitat-hubconnect plugin to allow faster cross-sharing of improvements

#241

All,

there is a new version of the plugin available on NPM with a bugfix for multi-sensor devices not updating temperature and humidity. In addition, the plugin now temperatures below 0. Apparently that never worked.

Thanks to @tsviper for finding these issues and testing the fixes with me.


How do I setup presence using Homekit and Homebridge?
#242

Hi. I am getting an error trying to set this up on Windows 10.

Here is the output:

[5/17/2019, 5:59:51 PM] [Hubitat hhm:0.2.8] Fetching Hubitat-MakerAPI devices. This can take a while depending on the number of devices are configured!
[5/17/2019, 5:59:51 PM] [Hubitat hhm:0.2.8] Refreshing All Device Data
[5/17/2019, 5:59:51 PM] Homebridge is running on port 57119.
[5/17/2019, 5:59:51 PM] [Hubitat hhm:0.2.8] Looks like your MakerAPI instance is disabled. Got code 500
[5/17/2019, 5:59:51 PM] [Hubitat hhm:0.2.8] I am stopping my reload here and hope eveything fixes themselves (e.g. a firmware update of HE is rebooting the hub
[5/17/2019, 5:59:51 PM] [Hubitat hhm:0.2.8] latest version on npmjs is 0.2.8
[5/17/2019, 5:59:51 PM] [Hubitat hhm:0.2.8] your version of the plugin is up2date

I've been cobbling together my config.json from pieces all over the place.

Any idea what the issue might be?

Also, what is the password supposed to be in the bridge section? Mac address of the hubitat hub? Mac address of the machine runninng homebridge? just random numbers?

Thank you.


#243

Maybe put your config file here?
The password is just random. Changing one character changes the link and can cause a refresh


#244

I've seen that error before when I didn't have the correct app_url or access_token from the MakerAPI app. As far as I know the info in the bridge section is not a MAC address or anything. You can make up your own values...I'm just using some I found in another example. If you run multiple instances of Homebridge you want them to be different though.

Here is my config.json if it helps:

{
    "bridge": {
        "name": "Homebridge",
        "pin": "444-55-666",
        "username": "CC:23:3D:E3:CE:35",
        "port": 51821
    },
    "platforms": [
        {
            "platform": "Hubitat-MakerAPI",
            "name": "Hubitat",
            "app_url": "http://10.0.0.54/apps/api/2230",
            "access_token": "bd2d7101-3be5-4t215-8450-a2581f9c143b",
            "polling_seconds": 300,
            "mode_switches": false,
            "hsm": true,
            "excluded_attributes": {
                "101": [
                    "battery"
                ],
                "102": [
                    "battery"
                ],
                "246": [
                    "illuminance"
                ],
                "247": [
                    "illuminance"
                ],
                "248": [
                    "illuminance"
                ],
                "774": [
                    "motion",
                    "illuminance"
                ],
                "776": [
                    "motion",
                    "illuminance"
                ],
                "777": [
                    "illuminance"
                ],
                "778": [
                    "illuminance"
                ],
                "933": [
                    "presence"
                ],
                "934": [
                    "presence"
                ],
            }
        }
    ],
    "accessories": []
}

Also make sure you reserve the IP address of your Hubitat in your router.