New C7 hub, cant get initial setup process started

Hey all, New C7 owner, moving over from smartthings. I set up hub, physically, last night, and i cannot get the thing set up for the first time. Using the portal.hubitat. com link, on my computer, i cannot find the hub, though i can find it on my phone using the portal site and advanced discovery. I do see the hub in my router's devices list (google wifi), and i have given it a DHCP reservation.

When i go to the IP of the hub in a browser, i get an "Error, Connection Refused" message.

The diagnostic page at port 8081 is working, and from there i have tried rebooting, i have tried, soft and full reset, i have tried safe mode, but nothing seems to be working.

My network is simple, no Vlans, just a single subnet. I have my router connected to a netgear unmanaged switch (GS308), with other dumb switches down the chain as well. I have tried the setup while connected to the first switch, and to another downstream switch.

The hubs light is blue, not sure what its supposed to be, but it only changed colors when i did the resets, and it went to red. I see there are other threads about initial setup, but none of their tips worked to get me going. I emailed support, but i suppose asking here also cant hurt.

Thanks in advance, ready to get rid of smartthings, not the best first impression though.

1 Like

Contact support@hubitat.com - they will process a replacement, which is what I think you need.

Also tagging @bobbyD.

P.S. I’m sorry that your first experience wasn’t smooth. OTOH, it can only get better! :grin:

Thanks, i did email them as well, just trying to get as many opinions on possible troubleshooting as possible

1 Like

Blue light staying on for a C-7 is definitely a problem:

thanks for this... ive had it plugged in and untouched after my last reset overnight, i would think that 12 or so hours should be enough time to get the software running???

If I recall there's an issue with chrome and auto discovery. That would not explain what you're seeing but just an FYI.

What version of firmware does the diagnostic page report? Just wondering if it's a firmware issue and upgrading to the current version might give it the kick in the *ss it needs. A guess on my part though... so take it for what it is.

yea, auto-discovery is only part of the issue, since i was easily able to get the IP by my router, and then by the reservation i set for the MAC address

firmware is listed as

Platform Version:
hub-2.2.3.148
Hardware Version:
Rev C-7
Hub ID:
c6a51e31-f71f-42b7-a0c4-6559a911ea47
IP Address:
192.168.0.99
Diagnostic Tool Version:
1.0.75

How would I go about upgrading the firmware if possible?

Hmmm my bad - you can't do it from the diagnostic page. All I can see is to revert to a previous version. I suppose you could try reverting to a previous version... if it's not a HW problem maybe that would give it the kick it needs? I don't see how it could make things worse. If it comes up I'd immediately upgrade to the current version :slight_smile:

Like I said, kinda making this up as I go along so do what you think is best or at least seek a second opinion.

Generally under 10 minutes .... So if still blue it can't find the software to load.

1 Like

The blue LED indicates that hub platform isn't loaded. There used to be a way for the enduser to load the platform. But I think it was removed at some point of time.

What do you think about my suggestion to try loading a previous version?

if i click previous version, there is no version there to revert to:

Brand new hub. No previous version :slightly_frowning_face:

Oh well! It was worth a shot! I assumed it would check the web for the previous version and download and install as needed... kind of like a Mac does. I guess it just restores from a locally kept copy. Learn something new every day :slight_smile:

I had similar experiences and forcing the port to 100 FDX on my switch solved my issue (even though it auto-negotiated at that) DHCP Handshake won't complete

Thanks, but I’m using un-managed switches, I don’t have an option to set port/switch negotiation rates.

@bobbyD I was told on reddit to @ you. I submitted a ticket last week and have been updating with new information as i have tried things, but have not had any response aside from the initial one. can this be looked into?

2 Likes

Please see my private message.

1 Like

mine did the same thing did you find a fix to this?

1 Like

I’m stuck here too. Just emailed support and waiting on a response.

Download the Hubitat app