New Android and iOS beta builds are available

The main changes are:

  • Toggle Map Type on Geofence
  • Landscape mode enabled
  • Auto load local dashboard by default (if available)
  • Auto switch to cloud or local depending on connection
  • Improved geofence presence detection
  • Improved app loading
  • Added option to disable rotation
  • Local hub discovery

Interested in using the beta version? It's open to public. Check out this post for more details:

10 Likes

The instant local dashboard access is much appreciated!

What's the Android version? I am not showing an update. Last beta update for me looks like July 22.

Same here.

Never mind forced an update check for apps and it showed up.

That worked. Thanks,

Updated Android app. Got "no response from hub" on Dashboard page. I have 2 hubs in different locations. Switched to the second hub and now can't switch back to the first hub. App hanged on Fetching User Data. Everything was fine before the update.
Edit: App removal and reinstall didn't help.
@chuck.schwer

@raidflex, @spalexander68 How did you guys force an update check? thanks

Love the load graphic! Load of bits that is really polishing up the app :+1::grinning:

@razorwing, I kept hitting the refresh button under My Apps. After about the fifth time, it showed an update.

Are we talking about the mobile app?

@razorwing, Yes. Android for me.

Ok, I have android but I must be having a senior moment. Going to app in the play store or in the phone doesn't give me a way to refresh or check for an update.

Is this the Beta you are referring to? I don't do that but I guess I could. I missed the Beta build in the dang title!

@razorwing, yeah beta. Here is a screenshot of my update button I kept hitting:

I put in a request to join. Phone is stuck at joining, maybe it's trying to tell me something. Anyway thanks for the help.

Should just take a few minutes to get joined up.

@spalexander68 Ok, I got it to work. Do you guys just do your phone or do you do the wife's also to make sure they are both working with the geofence?

@chuck.schwer
The main local hub dashboard page is working now in both local and cloud modes, but when I switch to the other remote hub the dashboard page shows this error:
{"error":true,"type":"AppException","message":"Not Found"}
The only difference between two hubs is that on the remote hub I still run under 2.1.3. Is it a problem?
By the way I see that in the new app version there is Advanced button which opens the hub upgrade function. I tried to upgrade the remote hub to 2.1.4, but nothing happened. Is it designed for local upgrade only?

@chuck.schwer Iā€™m using the IOS beta app and am unable to keep the geofence radius saved at its minimum level. It always resets to slightly larger than the minimum level, sometimes hours or days later.

This has been happening through several updates, any idea if there is a fix on the horizon?

Overall app improvements and new features are great. Loads faster, move through the app faster, dashboards load faster.

I do occasionally get a black screen when loading a dashboard, not on the same one each time. Go out and select again, it usually loads about 75% of the time, third time it almost always loads. Same thing happened on the previous version

Moving in the right direction

Now to see if the presence is any better
:slight_smile:
Rick

@patrick I'm assuming this text is wrong? Android 9 S9 app 1.3 build 57


Should say without?

1 Like