Native HomeKit and HSM

Are there any plans on adding HSM to the Native Homekit Integration? I moved most of my items over to that native support, but I had to leave my original homekit hub and automation up just to be able to arm and disarm HSM from apple home.

From what I've read here, HSM on Homekit isn't allowed and I can't find the thread currently that states this. So what I've done and finally was able to work as I wanted was to use the "Modes" in HE. Not as clean looking as a single button that displays what HSM is currently in, but it works. There is probably a dozen way to do this, but this worked for me. (sorry it's a long reply, but step by step-ish on what I did)

  1. You first need to create 3 virtual switches; I have Arm Away, Arm Night, Disarm. You have to use switches as Homekit don't recognize buttons.
  2. Then I loaded the native "Mode Manager" HE app
  3. Open the Mode Manager app and scroll down to " Set Mode with Switches". I have 3 modes, which can be changed or renamed in "manage modes" at the bottom of the page. Here you can click onto "Switches On" in "Away" mode and have it turn on when the "Arm Away" switch is turned on (this is the name of my virtual switch, yours could be different). I also have it turn off the other switches to ensure only one virtual switch is on at a time. You have to hit "Done with Switches" to save you selection.
    Do this for all modes that you want, again, I only have Away, Night, and Disarmed. Then hit Done at the bottom to continue.
  4. Go into HSM app and Configure automatic arm/disarm at the bottom. Once in there, at the top configure HSM to go into a particular setting when a mode is configured in HE. For example, I have Arm-Away when mode becomes "Away". Do this for all your modes and save at the bottom.
  5. Go into Homekit Integration app and scroll to the bottom under "Advanced". Turn on the "Expert Mode Switch". This will create the mode selector switch in your IOS Homekit app. Be sure to restart integration in the Homekit Integration HE app so everything works again.
  6. Open your HomeKit on your IOS device. Go to the "Mode Status" switch (It could be called something different, I'm not sure the exact name). If you turn on the switch, it will open up to the different modes virtual switches you can select (I had 3). What I did, was go into the setting for that switch using the gear icon, or on a Mac, right click and go to settings. In there you can go under "Group" setting and change to "Show as Separate Tiles". Now they will all show as 3 different tiles (switches) called Mode Status (or something like that). I changed to Disarmed, Night, and Away by deleting that name of the tile (hit the x) and the mode will be show in grey. Type that mode in and X out of it. It will save the name.
    So when I turn "on" the disarmed virtual mode switch in Homekit, that shows on, it sets HSM to disarmed, the Night and Away are turned off. When I look at Homekit it shows me the current status by what's on. Disarmed in this case.
    I hope this works for you, not perfect, but it does work. The only downside (other than having multiple buttons) is you can turn off that light (like disarmed) and now you don't know what your HSM mode it's in. Maybe there is an item in the virtual device that would prevent this, but I haven't found it yet. I've also moved these 3 switches to the home status tab...or it might have created it, I'm not sure at this point.
    Good luck all.

Not sure why it wouldn't be allowed. it works pretty solid on it with Hoobs as the bridge between homekit and hubitat. I left Hoobs up just to keep that functionality.

I didn’t set the rules, if I did I would have HSM as a native HomeKit integration. Be it as it may, the above is how I worked around the issue. My server crashed on me while I was on vacation and took out my home bridge server. I still had sharp tools, but I’m trying to get away from that so I don’t pay annually, this is my first step.

Download the Hubitat app