Nano leaf stuck “Sending” command

After updating my C5 today I’ve had a few problems now.

  1. Sunrise trigger not working.
  2. Dashboard sometimes does not update without refreshing. When you turn off / on a switch it sometimes get stuck on “sending” even when the devices works as expected. After a refresh of the dashboard the correct status is shown.

Anyone else seeing these problems ?

I have not updated yet, but I have always had trouble with dashboards not updating- especially on a desktop browser- unless I refresh. Are you sure this is new?

1 Like

Yep worked perfectly on the app before the upgrade. I was actually playing around with the dashboard a few nights ago and all worked fine, today after the upgrade seems to be buggy.

So no I’m thinking it might just be one device causing the problem.

I have a nano canvas and that’s the device which appears to be causing the problem. I’m just switch the canvas on and off and it appears to get stuck.

If you change it from the device page does it do the same thing? The driver might need to request a refresh or something (not a dev).

Ok this just gets stranger.

Switch nano off from the nano app.

Click refresh a few times from the device in Hubitat and I can see the switch value will go from ON/OFF randomly.

When the device is on and I hit refresh it never flips from ON/OFF.

Just to note when I’m refreshing the device it is not switching on and off.

Check a few z-wave devices and they don’t have the same problem.

So nano when off and hitting refresh in the console flip flops from on / off.

When the device is on it will always show on with no flip flopping.

So I reverted back to the previous version, hitting the refresh button a few times I can still see the ON/OFF flip flopping however it works perfectly from the dashboard. I must have clicked on and off 10/15 times from the dashboard and it worked perfectly.

So something definitely changed In the new version ?

Also reverting back worked without any problems.

Does the aurora behave this way when turned on and off via the driver?, or just the dashboard...

Hi Mike,

Thanks for the response.

Latest Firmware

  1. Switching on and off at the dashboard after about 2/3 attempts it will get stuck at sending. Refreshing the dashboard will show either on or off but normally not the true status.

  2. If I go into the devices section and click on / off it will mostly skip on either the second or 3rd attempt.

  3. Hitting refresh while in the device section and the device is off, will switch between on / off. Randomly in the status section. This does not trigger the device on and off in reality so it appears it’s only a status check. I had not seen this in the previous firmware however it does appear to be the same.

After reverting the firmware all has returned to normal. I can switch on and off multiple times with any problems. I also noticed when it would get stuck on a sending status the dashboard would also fail to update on other devices.

Hope this helps.

I just retested on the latest hubitat release on the C7 hub and I can confirm it’s still a problem.

When you get the “Sending” status from the dashboard of you change the brightness or select refresh from the device it appears to clear the problem.

Also if you hit refresh a few times on the nano leaf from the device manager it switches from ON/Off randomly. Like before it does not change physically.

Anyone else seeing this problem. ? It’s really easy to reproduce.


Hi Mike

Looks like a dashboard problem, I’ve just created another topic with the same problem when using a global var and connector.

The problem is reproducible on the latest os.