Mystery T-Stat changes in the middle of the night. Possible paranormal activity?

Ok, probably not ghosts but maybe the community can help me.
I have a Honeywell T6 thermostat, whose temp changes take their queue from mode manager.

Came downstairs at 3am for a drink of water and noticed heat was on, calling for 70*. I checked the dashboard and my mode was correct as "night" (read: should not have been calling for 70).

I went into the logs today, and the mode manager is operating correctly. Then went and checked the T6 history and in sure enough at 253a the tstat was set to 70*?
I check the day before (12/09) and again, this time at 247a.
Another day back and its 255a.

What could be causing these one off heating calls?


First check the device page and go through every rule that is used by the T-stat.

Some people have found that Alexa hunches can make unexpected changes. Not sure hunches does T-stats, and it seems an odd hunch to turn up heat at 3:00 in the morning.

Do you use node red or webcore or any other rule engines?

In every case where something happened that I didn't expect I eventually found it was doing what I told it to do. I just forgot or didn't realize the effects of another rule I created or forgot about.

Also check your logs at the time the change happened and see if anything else that happened at that time might give you a hint at what caused the change.

2 Likes

A bit of a novice here, do you see any other calls in the image below?

@terminal3 is right, but these logs won't show you what you need to see. You can see from the logs that the heatingsetpoint and the themostatsetpoint were set to 70 but the logs generated by the devices won't show you what set them. But if you go to the device details for that thermostat you can see what other apps are using it. I think the T6 can also be manually programmed at the thermostat itself. Is it possible there's a schedule local to the thermostat and HE is merely reporting what the thermostat itself is doing? Though the times do seem... odd.

This is Alexa, and she was cold, mkay. Give the girl a break, would ya. If she wants the heat at 70 at 3AM she is entitled to turn it up. You can't stop her.

download

But seriously, I haven't heard of her messing with thermostats either. It has always been lights up until now, unless the recent changes that are being made have put this into play.

2 Likes

And of course it is a ZWave thermostat, so... :slight_smile:

2 Likes

Excellent, a lead!
Any chance theres a way to turn off hunches?

"Alexa, disable hunches." Might take a quick look at thermostat scheduler... I dont suppose there's some weird mode transition happening? Though that would seem odd.

1 Like

Do you have a schedule programmed into the thermostat? I leave most of the "smarts" and scheduling up to the thermostat (ecobee). For example, my nighttime setback (sleep setting) is set to 60F and then increases to 66F at 5:30. Mine has been starting the heat at about 4 a.m. in order to reach the target temperature by 5:30. During this "recovery" time, the thermostat still shows "Sleep" even though it is actively satisfying the "Wake" setpoint.

I asked that too. But the times seem odd for a manual schedule. I wonder if the thermostat has an internal clock that's 7 min off, so something that HE thinks happens at :53 the thermostat thinks happens at :00. That would make the onboard schedule theory a little more plausible.

Happened again, no hunches from Alexa either. Thats disabled.
My understanding with the t6 is that when it is in wifi/zwave mode - there is no internal scheduling or programming.

When I go into app, thermo scheduler, then the gear, then events I see everything running on schedule proper (image 1)

The other images are when I click on main logs (left menu) device stats, select device, then events. Lots more happening there such as reporting (image 2)

Whats the difference in these logs?
This isnt happening everyday, for instance Sat night it did not change (image 3)

One more data point- check out how the reporting changed on/around 12/8.

@256peach and @brad5 - did either of you solve this problem?

I'm in the middle of debugging the same or a similar issue on my newly installed T6 - spontaneous, middle-of-the-night spikes of the heating setpoint (followed by lower setpoint adjustments) while the T6 is in the Sleep phase. For instance, I see the target setpoint jump from its programmed 60F up to 68F at 4AM and then issue subsequent lower calls at 62F or 63F when it should be waiting until the 6:30AM Awake time to bump up the temperature from 60 to 68.

So far my HE thermostat configuration is still very simple: I started out slowly with this device, using the built-in T6 driver, no HE rules, and so far the only scheduling has been run on the T6 itself with the simplified mode as described on pg 12 of the Professional Install Guide under "Enabling thermostat schedule when thermostat is included in Z-Wave network (optional)". I have been running it in Auto mode, even though we only need Heat this time of year.

Also, I have been running it solely under battery power for a few days but today rewired it to use the 24V "C" wire connection to make sure my anomalies aren't related to the device's power-saving "LSS" sleep protocol.

I DID have it successfully connected to Alexa but only verified that I could set the current temperature by voice command, no fancy stuff. I have temporarily excluded it from my Z-wave system to see if I get unwanted temperature changes from the thermostat running solely in non-networked "vanilla" mode, so that obviously removes Alexa from the picture for the time being too.

I have NOT resorted to a complete factory reset yet.

I also wonder if these temperature changes have anything to do with a possible misbehavior of the T6's "Adaptive Intelligent Recovery" feature (described on pg 17 of the User Guide and enabled by default out of the box on my unit with ISU option 425 set "On"). This seems like a relatively tweaky feature and one that could cause strange consequences in the initial training phase or if it exhibited a legit bug. Do you guys have that turned on in your units?

I had a T6 Z-Wave thermostat for 2 years and never encountered this issue. Can you try removing it from the Alexa integration? Just to confirm that it isn't been adjusted by "Alexa hunches"?

I was trying to help someone else... I actually have an Ecobee. Does not do weird resets in the middle of the night.

I don’t have one of these, but my Nest thermostat has a feature called β€œearly on” that will turn on the hvac to match the heating or cooling set point at a the scheduled time. It could be something similar, although it sounds more like a bug.

Yes. I found that even though the T6 disables it's native programming functionality when it is in wifi mode, there is still a toggle in the installer menu that needs to be flipped. Can look at the manual when I have a chance but if you take a peek, it should jump off the page at you. Lmk if that works.

Edit: word

Edit, edit. Also- all programming should be done on the hub- nothing on the stat itself.

Edit Edit: on the installer menu, code 120. Should be set to "occupancy"

Update from last night's testing: With the T6 excluded from the Z-Wave network (and thus disconnected from Alexa integrations) and running on it's own internal schedule (68F->11:30PM/57F->7:30AM/68F) I found it at a setpoint of 68F and current temperature of 63F at 6AM. This is clearly malfunctioning behavior that has nothing to do with interference from automation systems, so this morning after it warms up I'm going to do a complete factory reset on the unit and start building back up to desired scheduling and automation one step at a time - definitely with the unit's Adaptive Intelligent Recovery mode disabled - @Ken_Fraleigh this feature sounds similar to the Nest "early on" algorithm you describe.

I assume by "WiFi" you actually intended to write "Z-wave" here - and yes, local scheduling can be turned on and off when ISU #120 "Schedule type" is set to anything but "No Schedule"; I was surprised to see that setting "Schedule type=Each Day" allows individual programming for each of the 7 days of the week - don't think I saw that feature mentioned anywhere else.

1 Like

Yes. WiFi = ZWave

In my troubleshooting- Alexa hunches had nothing to do with the issue.