My scenes in Simple lightning does not work as they should: Lights doesnt swich off

As the headline of the topic tells you I have a problem with my scenes that I run through Simple lightning;
I have some Hue bulbs that are conected to Hubitat through my Hue bridge, two IKEA GU10-bulbs that I have installed in Hubitat directly, two Osram Smart+ outdoor outlets, three Innr plugs and one Telldus Zwave-plug. That are supposed to activate at different times or at sunset and then deactivate at sunrise or at different times of the day.

It worked good in the first couple of months but now they activate but dont deactivate so I have to manually turn the lights and plugs of through my dashboard.

Anyone who has any idea whats causing this?

By the way; The problem really stated to show after I had to do a soft reset of the hub after a powerloss causing a unsafe shutdown of the hub.

So no one has any idea about what may cause this issue..?

The best I could offer (for now) would be to turn on logging in the rules or apps involved in turning the bulbs on and off. This may shed some light (pun intended :slight_smile: ) on what is going on.

Beyond that I'd be contacting HE support to try and work through the issue with them.


1 Like

Yeah I gues I’ll have to do that. As far as I can see I cant find anything in the logs. But I’ll keep searching.
My guess otherwise is that it is the IKEA bulbs that f**ks up my system and that I should probably keep them in my IKEA gateway.

I’ve tought of contactinf support and I gyes that option gets closer and closer right now.

1 Like

Maybe thats whats causing problems aswell although my problem is the opposite. Lights and plug sockets go on at sunset but doesnt go off att sunrise and at specific times.

The above was a specific case of a restriction that ends at sunset + offset. What is your situation?

I have two osram Smart+ outdoor switches, 2 IKEA gu10 bulbs that are connected through Hubitat, and 3 Hue bulbs that are connected through Hue gateway that are supposed to come off at sunrise but they dont. I also have a Telldus smart plug socket (zwave) that powers on at two times a day and are supposed to power off after two hours. But it doesnt turn it’s power off.

Evwrything are done with Simple ligthning and worked until a couple of weeks ago until I had a unsafe shutdown of the hub due to a power loss.

Have you tried a Soft Reset and restore of your database? Download a backup first of course.

1 Like

Yep! I’ve tried that already. Didn’t solve the problem.

One thing that has changed over time though (I’ve had this problem for about three weeks) is that in the beginning I had another 4 Hue Lights and three INNR SP120 plug sockets that also suffered from this problem but wich automations now behave as they should. This didnt happen after the soft reset though but much later.

It's impossible to tell by your descriptions what might be the problem. Need to see the app setup page, turn on logging, catch the problem in the logs, etc.

Ok, I’ll turn on logging for the devices and we’ll see if I can find any logs that might help.

Edit: Debug logs turned on for the troublesome devices. I’ll check tomorrrow if I can see anything.

Please turn it on for Simple Automation Rule also. Also, you don't need debug logging for the devices, just descriptionText logging.

1 Like

Ok so I got a few errors..:

2021-04-14 05:39:00.096errorjava.lang.NullPointerException: Cannot invoke method multiply() on null object on line 785 (afterSunriseHandler)

I also get this error from a device not used in any if the scenes:
org.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: is applicable for argument types: () values: [] Possible solutions: find(), print(java.lang.Object), find(groovy.lang.Closure), print(, print(java.lang.Object), run() (ping)

dev:1212021-04-14 06:42:46.209

Please show the rule setup page. I believe we found a reported bug wrt after Sunrise as the trigger for the anti-action (e.g., off after on).

Heres the setup page for the automation that uses sunrise

And heres the setup for the automation using specific times for on and of and that controls a plug socket.

Could you show the Settings section (top of page) for the App Status page for this. Gear icon at top. For the sunrise/sunset version, the one that throws the error.

Here it is;

Thanks. I just tested this with the new release fixes, and it works as expected. So, give it shot when 2.2.7 comes out. In the meantime, you might try removing this rule and recreating it. That might fix it.

1 Like