MY Q Suddenly Erroring

So for whatever reason my garage doors were not automatically shutting, so I popped in to Hubitat and when I click my Q app it gives me this

MyQ
Unexpected Error
An unexpected error has occurred trying to load the app. Check Logs for more information.
Error: Bad Request

I removed the app, re added it, same thing.
The code has been unchanged for months, since I initially did it.. Any reason why this would just randomly happen?
thanks

Chamberlain updated the MyQ API. @dman2306 ported the updated ST app and driver to Hubitat.

Details in this post and the ones that follow it.

I just found that actually... trying to work through it... kind of a pain to have to delete devices :slight_smile: but such is life..
especially when its tied to Google home, ifttt, sharp tool,s safety monitor, etc etc etc haha

thank you

So I
Removed garage door 1 and 2
Deleted the Drivers code.
Re added the drivers code new, from here. hubitat-myq/myq-garage-door-opener.groovy at master · dcmeglio/hubitat-myq · GitHub

Tried to re add the My Q user app... I do get the same error again.

It didnt matter as much during summer, but now in the north with a heated garage and kids that forget to close the door :slight_smile: I want it to check every 15 minutes and shut it if its open :slight_smile:

Are you using the old app, or the new app? The new app should not give an error. You need the new ST app and driver ported by @dman2306.

I must have misunderstood one of the earlier posts I read... I thought we just needed to update the driver... I replaced the app driver code as well, and it appears now I am cooking with gas... Havent tested doors yet, but Soon :slight_smile:

whats the github for the new app?

thank you so much, will install this tonite