My Hubitat C7 has become unreliable after update

Cannot control devices from the hub (or Alexa). Oddly, at different times during the day, the integration between Hubitat and Alexa begins to work, and I can control certain lights for a limited period of time, but then it breaks again and stops working until it randomly works again.
But currently, I'd say it's working only 10% of the time based on observation.

I did try cutting power for 5 minutes, I did a soft reset and reverted the firmware. None of these have worked.

Ok, Alexa is a external cloud platform so lets remove that for the moment. Can you control things from the hubitat app on your local network? Are the devices LAN based or zigbee/zwave?

2 Likes

Is it possible you are having internet issues, that your router did an update, or something like that?

Can you ping Amazon? (via the Settings tab, networking, in Hubitat)

Errors in logs?

Static IP or DHCP in network settings?

So, at this moment, things are working, both with Alexa and the Hubitat app. I'll wait a bit and expect it will just stop working again soon.
The Hubitat is connected via LAN, the devices are mostly Z-Wave, and a couple of Zigbee.

Network tests in Hubitat are showing al good. Can ping Amazon and other places fine.

IP is DHCP, but I can try and change to static. It's been DHCP for the past 3 months and the IP has not changed.

As of errors, I got a couple of Alexa ones like this today and yesterday:
2023-04-12 12:35:01.342 AMerrorError making Call to Alexa message gateway: {"header":{"namespace":"System","name":"Exception","messageId":"52a05f3c-e82e-44f2-acca-4c3ab01bbae5"},"payload":{"code":"INVALID_REQUEST_EXCEPTION","description":"com.amazon.iota.container.exception.NoCorrelationSessionFound: No active session found for correlation token :

It's back to not working again. Both Alexa, the hubitat app on iOS and the web hubitat portal cannot control devices.

Further info, I changed to static IP now.

One thing I noticed in the logs, it will register physical switch presses, but it will NOT register presses from the app or Alexa. A bit earlier, this was working.
For example when it was working:
2023-04-12 11:11:16.411 AMinfoFamily Room was turned on [digital]

Example when it now only works from the physical button (digital does not register in logs):
2023-04-12 11:36:43.326 AMinfoFamily Room was turned on [physical]

I've seen many posts having issues with recent firmware since the arrival of the C8, enough to discourage me from upgrading my C7. i'm always slow at making upgrades to allow time for bugs to get squashed. i feel for these people where a 5 min upgrade results in hours or repair time though i guess there are many more who have no issues and therefore have no need to comment.

I havent upgraded since the C8 v 2.3.5 arrived. Who would agree it is sensible to continue with v2.3.4 if all is working ok?

This worked for me........

bertabcd1234Ambassador

3d

I would just shut down from Settings > Shut Down, wait until the LED turns red, unplug the hub from wall power for at least about 30 seconds, then plug it back in. This will fully power cycle the Z-Wave radio and is one solution to a crash if the hub doesn't bring it back on its own (it's supposed to, so this is rarely necessary anymore, but it can't hurt). Contrary to some advice, just 30 seconds would be enough for this.

A soft reset or restore is unlikely to help, as that affects only the regular hub database, not the Z-Wave radio contents. But if it does keep happening, it may be good to see if you can figure anything else out. Nodes 0x4F and 0x56, for example, look suspicious in your screenshot and would be good to remove if you can (but see if they look normal again after the full restart just in case it's so messed up that this display isn't right, I suppose!).

1 Like

If everything works and newer updates don't have a new feature that you really want, then there is no reason to update.

2 Likes

That right there says it was not the update that caused the problem.
What hub firmware are you currently running?

Since reverting to 2.3.4.153, I haven't gone back to 2.3.5.

I tried shutting down the hub from the app, waiting for the red light, then unplugging for 30s+. Plugged back in, things works for a brief moment (seconds really), then got hung up again.

I can't imagine it's a hardware issue. It still seems to see the Zwave network and register physical changes, it just can't control anything most of the time.

Is the issue is primarily involving zwave devices:

Please have the hub running for at least 12 hours during a time the devices are in use, and then get screenshot(s) of the entire Zwave Details page AND the topology map. You can use https://getsharex.com/ "Scrolling Capture" feature if you want to try and get the details all in one screenshot.

When you post please state how long hub has been running at the time of the screenshots.

1 Like

Ok, hub's been running for about 20 hours now. Things are still mostly not working.

I guess I'm too new to be able to post images or links. :confused:

Trying to put this on my Dropbox:
www.dropbox com/s/nrdy8fflhsz9nyo/hubitat.zip?dl=0

Join the Owners group and you'll be able to post images.

https://community.hubitat.com/g/owners

Clickable link Dropbox - hubitat.zip - Simplify your life

Do you have a "Update Firmware" button at the top of the Zwave details by chance? If so, click it and do the update.

Nodes 0x24 and 0x25 both have no route and low neighbors, are those devices functional?

Everything looks pretty good, makes no sense that things would not be working.

Have you tried power cycling the devices themselves at all? Either at the break or air gap pull tab if they are dimmers.

No update firmware for zwave it seems.
24 and 25 are the kids’ bedrooms. Not sure why they have not many neighbors. There’s 2 other zwave devices right beside their rooms.

I’ll pull the tab on both kids lights to shut off the devices overnight. I’ve also just rebooted the hub to see if that helps anything.

Bringing some finality to this issue, the problem apparently was a switch in our basement bedroom that never gets used. It went defective and was causing havoc on the Z-Wave network.
After cutting off power to this switch, the network slowly began to recover. After a few hours, everything was normal again and has been working just fine for the past couple of days now.

Thanks to all that helped on this. I was getting close to doing a full reset and manual re-add of all devices (at which point I probably would have discovered the issue anyway, but glad I didn't have to go down this road, I was dreading it).

1 Like

please talk us through the process/steps you done to identify your fix

Quite simply, I went down to the basement bedroom one day to clean stuff up. Tried to turn the light on, but it wouldn't turn on.
I noticed the LED was blinking on the switch, so I pulled the power off the switch and left it offline.
After a few hours I noticed that Zwave was working properly again. Commands through Alexa weren't misfiring, and after stable operations for the next 2 days, I concluded that it was the defective switch that was causing the problem.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.