My Hub locked up yesterday


#1

FYI
When I arrived home yeasterday I could not operate my Sengled Zigbee bulbs or my Tradfi plugs. My Zwave and Wifi devices worked.

I was unable to reboot or shutdown the hub from the portal. I had to physically unplug the hub from power and then plug it back it to reboot it. After the reboot it has been working fine for one day now.


#2

The zigbee radio is the first to go when your hub begins to lock up. Did you contact support? They can sometimes take a look and see if there is a user app or something that is "running away" with system resources. What types of user apps/drivers are you running?


#3

I did not contact support.

I have these apps running:
-Advanced Button Controller
One 5 button Pico Dimmer
-Button Controllers
Four 2 button Picos
-Groups and Scenes
Two groups
-Hubitat Dashboard
About 20 tiles
-Hubitat Simple Lighting
7 rules
-Lutron Integrator
-Rule Machine
no rules


#4

This may be completely unrelated but if you have a C5 - be careful about overheating. I had mine sitting on top of a SONOS Connect and was getting frequent lockups. Simply by flipping it over so the bottom "vents" were exposed seemed to do the trick. Lockup issues appear to have been resolved.

On the other hand my main C4 hub just locked up and I had to manually powercycle. Had been fine for a while until the last few updates. Also some rules have been mis-firing a little - have a simple switch rule that triggered twice in the morning (before sunrise) a few days ago. Not frequent or consistent enough to really worry about so have not followed up on it - seems okay now. My upstairs C4 has been working fine. Both C4's contain a mixture of Zigbee/ZWave while the C5 is just a "controller/internet" hub. I do have custom drivers and apps which are always a question mark and I will disable if things start to become a bigger issue.

I wonder if the nightly "cleanup" routines can cause issues if things have been corrupted?

Note: I have not done enough troubleshooting to blame the latest updates.


#5

You seem to only have one custom app installed and I can personally vouch for the ABC app :stuck_out_tongue_winking_eye:
Do you have any custom drivers installed?


#6

I and many other will vouch for your excellent app Stephan. NEVER has caused me any problems.

Overheating and custom drivers definitely something to look at since there are no apps present that would be causing the issue.


#7

Yes, I'm using 4 drivers:

**

  • Xiaomi "Original" Temperature Humidity Sensor - model RTCGQ01LM
  • & Aqara Temperature Humidity Sensor - model WSDCGQ11LM
  • Device Driver for Hubitat Elevation hub
  • Version 0.8.2

/**
/*

  • Shelly Switch Relay Driver
  • Copyright © 2019 Scott Grayban

  • Xiaomi "Original" Button - model WXKG01LM
  • Device Driver for Hubitat Elevation hub
  • Version 0.8.5

/**

  • Xiaomi Aqara Button - models WXKG11LM / WXKG12LM
  • Device Driver for Hubitat Elevation hub
  • Version 0.6.5


#8

The Xiaomi drivers from @veeceeoh should not cause any issue. A lot of us, myself included have been using Keith's drivers for a long time. They don't cause lockups. I use all those same drivers.

I do believe the Shelly Switch Relay Driver is fairly new. This is not a slight on @sgrayban in the least, but there could always be undiscovered issues in newer drivers. You may try disabling that for a bit to see if things improve. If they do, please reach out to Scott. He's very helpful and I'm certain will want to get to the bottom of it, which will consist of collecting logs first and foremost. By the way, do be sure to check your past logs and current logs for errors. You can search the past logs for "error" and if there are any it will appear straight away.

Keep in mind, there's no need to remove any app or driver. You can disable them by simply checking a box. It's a very nice troubleshooting tool on HE.

Check these two docs for detail on how to disable Apps and Drivers.

https://docs.hubitat.com/index.php?title=Apps
https://docs.hubitat.com/index.php?title=Devices


#9

There are 2 ways to make the hub lock up with my driver.... polling every second and/or the device is offline and not connected to the WiFi.

I tested those issues weeks ago and yes it will slow the hub down to the point its not responding... it's takes a while but it will.


#10

Your Shelly drivers poll the device periodically?


#11

There is a set number... 1 5 15 and 30 minutes. There is no 1 second poll. The default is 30 minutes. The only way to do a 1 second poll is by creating a RM to do so and that is the users fault not mine.


#12

I got tired of chasing the lockups. I have two hubs...they reboot each other every night. Haven't had a lockup since. :slight_smile: yep totally the cheap and easy way out. But no one comes home to a locked up house anymore.


#13

Off topic I know but...........
Hmm. :thinking: Very interesting. How did you achieve this. Sounds like a great idea.


#14

Use RM or @ogiewon's HTTP momentary switch to send (as an HTTP POST):

http://hub_ip_address:8080/hub/reboot


#15

I know, I know, it's not a fix. But I was spending so much time trying to trace down code/etc. This was just easier. And honestly the house has been much much better ever since.


#16

I've tried this and nothing seems to be happening.
I can see the post command in the logs from the sending hub,

image
but nothing in the receiving hub.
I have both hubs password protected could that be the issue?


#17

Yes!


#18

Yes. Just tried disabling password protection and the hub rebooted as expected.
Thanks again.


#19

How does one do this with only one hub? Does sending the http request to http://localhost:8080/hub/reboot work? Or is there a "more official" method?


#20

That'll work as long as you don't have a login setup.