Multiple odd issues going on

In the last couple weeks or so, I've suddenly had some seeming unrelated odd things happening. The hub is on version And there is nothing new in the house that would cause interference. No idea if it's the hub or could it be my router.

The fist thing is in the bathroom. I have a temp/humidity sensor in my bathroom with a Shelly relay on the fan switch. When the humidity gets to a set level the fan comes on, then off when below the set level. I get out of the shower, and realize the fan never came on. The battery was showing 69%, but I changed it anyway, and no luck. I can manually turn the Shelly on and off in Hubitat web page. I didn't think to check the logs until last night, and turns out it has not shown any reading in over a week. But even with the new battery, it just won't show anything.

The next issues is with smart bulbs. I have two in my living room, each in a lamp, grouped. Then I also have four total outside. I have a Zooz remote that when I push one of the buttons, turns off all of the lights inside the main part of the house, and turns on the bedroom lights. When I got up this morning, one of the lamps was still on. Looking at the log, it never turned off when I went to bed. I must have been dead tired to not notice.

Later when I went outside. one of the lights was still on. Those are set to turn on about sunset and off just after sunrise. But, when I looked in the app, it showed that one as being off. I was able to turn it on in the app then back off, and the light went out.

Now the latest issue with the living room lamps again. I have a button in the app to toggle them both on or off together. I push the button, only one comes on. So I go to the webpage, and manually turn the other on, but it won't respond. The bulbs have a lot of miles on them, so I thought it might be burned out. But I turned the switch on the lamp off, then back on, and the bulb came on and is now responding normally. But, something else odd with that is it's set to remember it's previous state. I'm not sure if it stayed on after the switch was turned back on because that's what the app was set for, but I'd think it should have turned back off since the command to turn on was already sent.

In the spirit of "check the obvious stuff first" -
When I have had unexplainable on or off activity I have mostly been able to trace it back to Google Home (I understand the other online home automation services have similar behavior).
I also find it helpful to look at each "offending" device's device page and note the list of apps "In use by" at the bottom of the page. A few times I have forgotten I had a rule . . .

1 Like

I would start by just rebooting the hub and if you want to go the extra mile go to the backup settings, download a local backup and the restore it right away (this is also does a soft reset which cleans up the database). The backup restore has been found to resolve some memory issues and low memory can cause the symptoms you describe.

1 Like

So the latest is this. The bulb issue hasn't happened again, so maybe just some really one off crap going on.

I had already rebooted the hub after updating, so maybe something with that. Who knows. But on the temp sensor, I ended up just deleting the device and re adding it and now it works. Maybe it went wonky when the battery got low.

What bulbs are you using?

Similar to a comment I have made elsewhere, I feel like it would be easier to focus on one issue at a time. These may or may not be related, if they are and can be solved with the same fix, that's great, but it makes it hard, IMHO, to lump them together in one topic like this. Just my 2c...

The one inside is a Sylvania, the outside one having the issue is a Sengled.