Multiple DNS

Is there a specific way of using multiple DNS servers under the network settings ? Or just one entry?

I experienced a DNS failure and i didn’t find any documentation relating to that …

This is the only documentation I'm aware of, besides scattered forum posts that mention an HTTP endpoint you can use to do the same or some additional things manually (or on a C-3/C-4 where this UI does not exist): Networking - Hubitat Documentation

For more on that HTTP endpoint, see posts like this one: DNS bug in - #11 by gopher.ny

In neither of these have I seen multiple servers specified (not proof that it isn't possible, though I might infer so based on this). I suppose @gopher.ny could confirm for sure.

If I were to do this myself on my home network, I'd probably use my router's IP address, which also does DHCP and DNS for me and nearly every client connected to it (in most cases, DNS would get passed upstream anyway, but...if that fails, so does most of my network, so I've got bigger problems :smiley: ). Not sure what "failure" you experienced or if that would help your case.

My router is in bridge mode and the DHCP server is after it. It also serves as the DNS server. The DHCP server failed (offline) and HE had static IP assigned with one DNS entry which was the offline DHCP/DNS server.

While in outage, i tried using a comma (,) as a separator and while it took it, it didn’t revert/use the secondary.

The way it's implemented allows a single DNS server. It's an artificial limitation, though, and may be changed.

I'm running a C-7 on with static IP, and when I configure a single DNS server it works fine. But the hub's DNS resolution fails entirely (and therefore kills remote administration) if I configure multiple DNS servers (e.g.,, ). This is despite the fact that the label for the field in Settings says, "DNS name servers, comma separated:"

Did you try with a space after the comma? The example on the setup page has a space there.

It does work with a space, which is curious because I tried to include one and it didn't seem to accept it. Perhaps user error. Still, it shouldn't accept it without a space and not work.

1 Like

That should work, space or no space. Going to double check. Maybe will add a check for weird characters.


Download the Hubitat app