Motion lighting doesn't support zero second fade time


#1

Hi,

I am attempting to create a Motion Lighting app that immediately turns a Zigbee dimmer on. When I set the fade time under "Select a fade time for the lights", the app will save & store values greater than 1, but will not save the value of 0 needed for instant turn on. As a result, path lighting doesn't work very well since there is a delay while the dimmer fades on.

Ps: I validated that the Zigbee Dimmer (Leviton Vizia RF) works with instant on (zero second fade time) by setting it directly from the device control page.

Any thoughts? Thanks!


#2

how do you mean doesn't work very well?

(If you just want to turn it on/off use "Turn on Switch" instead of "set these dimmers")


#3

In the options for the dimmer just use set dimmer to whatever you want.
10, 20 50 100%.
Don't use the face option.
This way when the rule is triggered it will turn on to the level you have specified.


#4

@broberg -- sorry, to be clearer what I mean is:

For the Leviton Zigbee In-Wall Dimmer (DL6HD-1BZ), if I send a "set level" via the device page with a blank "Duration", it fades in over 1-2 seconds. If I "set level" with a duration of 0 explicitly, the light comes on instantaneously.

That relates to this bug in Motion Lighting. When you save a 0 second fade time, it doesn't actually send a 0 second duration with the Set Level command. As a result, the light slowly fades on instead of turning on instantaneously. That greatly impairs a path lighting use case since the light operates fairly slowly as you're walking through an area.

Requested fix: the motion lighting app saves a zero second Fade time and sends that along with the set level dimmer command.

Tagging @bravenel too since I believe this is a relatively straightforward bug in Motion Lighting.


#5

I will look into this. I can imagine the cause...

Update: found and fixed. Will be in next release.


#6

Amazing — Hubitat just keeps getting better. Thank you!