Monoprice Relay Inclusion Mode

Trying to add my Monoprice Single Relay 11989 to Hubitat.
Excluding the relay was a bit messy, it was hard to tell when it was finally removed.
I did get a successfully excluded device message in SmartThings.

Now I can't seem to get it to be included.
I've extensively flipped the switch 4 times, I've even opened the gangbox and pressed the configure button four times as well. I've held the button down in all sorts of combinations. I see the light inside the relay flash, but the relay will not include with Hubitat or back to SmartThings.

Any ideas what else I could be missing in the pairing process?

I’ve always had problems including/excluding my Monoprice dual relays as well. I’ve had issues on Smartthings, Vera, Homeseer and Hubitat (yes I’ve been on all the platforms at some point). Hubitat was probably the best actually. I own 5 of the dual relay ones and some of them worked fine and others were a pain. I eventually got them added so just keep trying. I’ve had the best luck pressing the button four times like you said but sometimes I’ve had to flip the switch on-off four times and sometimes going off-on four times worked better. Someone else has mentioned holding the button on the relay while you power it on but I haven’t had to do that on any of mine. The good news is once you get them added they work great.

1 Like

We have a Compatible thread. We have an Incompatible thread.

Maybe we need a "Price isn't worth the Hassle" thread? To protect the next buyer from this level of grief.


Thanks @tsviper for the reply, I'll keep at it.
@csteele I agree, I'm going GE switch from now on. Buuuut I'm cheap and need to get this bugger working.

I don't have the dual relay model, but I'm glad to hear people are using these.

Will update if I get it working.

I can't say its the same but I have a Monoprice motion sensor. It too was a bugger to pair.

I tried repeated times and at various distances. I finally got it paired when the unit was ~3 feet from the hub. I had no luck at 6" nor at 12 ft. I can't say the distances are even a real factor but 3' and many tries finally got it paired.

Regarding distance. An unscientific observation from when I first received my hub and it was on my desk with a few Leviton modules. It seemed at that time that having the module too close to the hub impeded the pairing. I can't say its really a fact but it seemed to me there is a "sweet" spot of 3' to 6' where I've had the greatest success with problem devices. Having said that I've also paired devices that were 25 ft away from the hub.


Awesome info! Thanks!
My hub is ontop of my SmartThings hub which I know can't be good, and is not the plan long term.
I did in fairness unplug the ST hub when I tried once or twice.
I'll keep at it when I feel less frustrated.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.