Monoprice 15270 Contact Sensor, C7 and S0 Inclusion Problems

I am trying to move one of my Monoprice's 15270 contact sensor over to my C7. The inclusion process works, but the device is not seeing any open or closes. The contact state field doesn't show up or get populated. I went to the Zwave Details page and noticed this sensor just automatically pairs with S0. It never comes up and asks you which security to choose, so I can't say none.

I know this sensor works fine, as I had it running on my C4 for over a year now with no issues. I even put it back onto the C4 and it works perfectly. I then exclude it from the C4, and go over to the C7, exclude it and then include it and the same S0 security happens.

Unfortunately, if a device only supports S0 security, it is automatically selected on the C7 without an option to unselect security. The only way to pair it to a C7 without security is to do the pairing with a UZB dongle.

An other option would be to use the new Hub Mesh option that came with Hubitat Firmware 2.2.4 to link the device between your hubs.


I do not want to do that though. I am separating out my zwave device to my C7. That was the point of getting the C7.

I get it! If you do decide to get a UZB stick though, there are some cheap ones from I got myself one from there for another reason, but also used it for this purpose.

1 Like

I'm following the advice of @Sebastien, as well as Zooz tech support (See below), to use my Aeotec Z-Stick Gen5 Plus, Z-wave Plus USB Stick to migrate these pesky motion sensors to my C7 with 'No Security'. Seems like the S0 default for your Monoprice motion sensors and my Zooz and Fibaro sensors are causing the failed inclusion issue....

Zooz Technical Support (Maggie)

There is an issue specific to the Hubitat C-7 platform which doesn't allow non-secure inclusion for S0 devices. There's currently nothing we know of that could possibly address the problems on the device side but we're actively looking for other solutions to this issue.

The only known workaround is to use a 500 chip Z-Wave stick, add it as a secondary controller to Hubitat, and then use PC Controller to add the sensor without security to the network. Would you like to try this solution? We can send you a loaner stick if you don't have one.

Here are the step-by-step instructions on how to add the ZSE40 without security using a 500 series Z-Wave stick:

  1. Include the Z-Wave stick as a secondary controller using the PC Controller software (you can follow the first 4 steps in this support article to set the stick up using the software): In Hubitat, click on Discover Devices > Z-Wave > Z-Wave Inclusion and click on Classic Learn Mode in the PC Controller window. Uncheck any security boxes that Hubitat prompts.
  2. In PC Controller, click on the new PC Controller device created (Node ID different than 1).
  3. Click the 'Add' button.
  4. Click the Z-Wave button on the ZSE40 twice quickly to put it in inclusion mode (the LED indicator will flash quickly). If you open the logging screen in Hubitat, you will see activity including an Add Node completed message.
  5. Go back to the Z-Wave details page in Hubitat and check to see the sensor has been added. There should be "None" in the Security column.

Note: I found that I had to restart my hub to see the new device(s).

Also note - I think my UZB stick is using a 700 series chip and the process above worked for me:


And apparently this isn't a Hubitat issue exactly. The 700 series chip apparently requires devices pair a certain way. I think sensors, and locks are the main ones affected by that.

So other hubs are going to run into that issue too, if/when they start using the 700 series chip too.

I bet Hubitat developers and support would LOVE to not force a certain pairing method, I am sure it would make their lives easier. But unfortunately, that is out of their hands.

1 Like

I really, really hope they (Whoever makes the Z-Wave requirements) remove that requirement!



I don't know if it would do any good to contact them, they probably don't listen to end users. But I sure would like to express to them how "wonderful" their standard is, and how it really is breaking lots of stuff in real life use.

1 Like

I haven't done this but before I go and try and buy a z-stick to include some of my sensors that only include using S0 do you have to keep the secondary controller setup in Hubitat after you get the sensor joined or can you turn it off?

When paired at no security, you should be able to un-pair the controller and stop using it. If you want to keep it paired, it should remain powered. I left mine on the mesh and just left it on a USB switch that is always powered.

1 Like


The only issue I've found with that is eventually other devices start to try and route through it which can be problematic if you end up moving it around or just unplugging it (ghost routes). That recently happened to me using a UZB-7 and my laptop. I should have known better of course..

Good point!

(I checked mine and it is not repeating... Good! - Almost everything goes through a single Inovelli Switch that is maybe 6 feet away from the hub...)

1 Like

Put that switch to work!! :slight_smile:


Oh, it’s working! :wink:


Thanks all for this post. I was able to add a couple of monoprice contact sensors and the fibaro motion ZW5 sensors without S0. Trying to make my mesh strong and happy on the C7.

1 Like

Weird I am now able to add these monoprice 15270 contact sensors to my C7 and it added them with S0.

Yes, that is because they only support S0 (well, either S0 or no security; they don't require S0, but the point is that they don't support S2) and don't have a separate pairing method for secure vs. non-secure pairing. As mentioned above, the C-7 will choose S0 without prompting in this case, so it's your only option--unless you use a secondary to controller to include it without security, something I'd recommend if you have a lot of devices like this and don't care to use S0.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.