Mode Manager "invisible" setting - how do I remove it?

So inside the settings I see this rule:

But it doesn't show up:


I think it may have happened when I renamed a mode, or perhaps I used to have this rule and deleted it. Not sure.

But how do I get rid of this mistaken setting? I tried the obvious thing of setting another rule for Night and then removing it.

It's harmless. It came from an offset of 41 minutes after Sunset for something to do with setting up Night mode. You probably can't get rid of it now.

It's not harmless - it triggered at that time and all the lights in the house went off (which is what I set Night mode to do). See log:


The timestamp is exactly right for 41min + sunset. Evening is 40 minutes from sunset, which turned on one minute earlier.

Open the app and hit Done, and then show the Scheduled Jobs from the App Status page.

Or better, yet, so screenshots of the Mode Manager setup page, and it's App Status page in its entirety. There is not enough context around your original question.

Under scheduled jobs it has jobs for 40 minutes after sunset and 41 minutes after sunset, so it's active.

I figured out how to reproduce it:

Pick a mode, and click on "At this time", then do Sunset + offset and click done. Then go back into it and this time under "At time, sunrise/sunset or Variable?" pick "No Selection" and then click done.

If you do that your sunset time gets stuck in the settings and you can't get rid of it.

I tried putting in the same exact offset again, and saving. Then this time doing "Erase Time Setting" and the time is still listed in the Settings, but the Cron job vanished.

1 Like