Mode Manager crash on 2.2.9

I updated yesterday and my C7 is at Whenever I try to access the Mode Manager app from the Apps screen, I get the error below. I really don't want to uninstall and reinstall this app - there are a ton of settings that I would hate to redo.

What options do I have? Hope Hubitat fixes it? Revert to an earlier version? Is there something I can do to try to work around this? This is my first real issue with Hubitat, so not that familiar with my options.

I found this when I tried to figure out why one of my automations was not running, and found that the mode was incorrect. It looks like some of the functionality still works, and I can still set the mode manually from the dashboard.

2021-10-09 04:40:03.842 pm errorgroovy.lang.MissingMethodException: No signature of method: is applicable for argument types: (java.lang.String, java.util.ArrayList, java.lang.Integer) values: [Day, [Sunday, Saturday], 2] Possible solutions: wait(), any(), trim(), grep(), split(), size() on line 183 (method mainPage)

This is a reported bug that has been fixed for the next hot fix release. The app should still work in the meantime the way it was configured, and the fix will make this error go away without you having to remove it or anything like that.


Wow - thanks for the quick reply! Any idea when that will be available?

Probably on Monday.


Get the same error but the app isn’t working either

Changed to a completely wrong mode at a completely wrong time

Here is the only log I can access

This is the error reported earlier, that comes when you access the daily settings. Wait for the hot fix release on Monday the corrects this bug, and see what happens after that. in the meantime there are two possible work-arounds: (1) roll back to 2.2.8, or (2) remove Mode Manager and replace it without using daily settings.

This now fixed in new release:

1 Like

Thank you! I can now see Mode Manager's settings again.

Download the Hubitat app