Missing Button from Smart Switch (Zwave)

I bought one of the GoControl Smart Switch/Buttons, that use Zwave. I only got one, to try it out, see how it worked, and to test how to use the Button Controller, Simple Rules (automation) stuff, and so on..

I've hit a bit of a roadblock, or at least I think I have.. The switch/button (the manufacture calls it a "switch" but according to Hubitat its a "Button" so I don't know what to refer to it as..) The issue is, that the thing has 2 (two) buttons on it, but the driver (device type: Generic Z-Wave Button Controller) only see 1 button. Well at least it only does when it comes to using it in the Button Controller app, Simple Automation Rules app, and so on.. However on the actual device page, under the "Current States" if you press button 2, it shows that button 2 was pressed (or held, or released)

In the simple automation rules app, if I try to set the "Which button number? " to "2" it tells me it must be 1 or lower. And under button controller app, it only gives the option for "1" in the drop down..

So how do I get it to let me use both buttons?

For some reason, the device is indeed only reporting one button--see numberOfButtons: 1 under "Current States" in the upper right of that screenshot. This is what a lot of apps that help you assign actions to button numbers will use so they don't show you more than you can do. It should have been set correctly automatically by the driver upon pairing. Since that didn't happen, as a workaround, you might be able to:

  1. Change temporarily to the "Virtual Button" driver (choose that in the "Type:" dropdown and hit "Save Device");
  2. Enter "2" (no quotes) in the "Number of buttons" preference and hit "Save Preferences"; then
  3. Switch back to your desired driver ("Generic Z-Wave Button Controller," I assume) and hit "Save Device."
  4. Use the custom co

Thanks, that seems to have worked.

Now to just figure out how to get it to dim the lights, without going past 0 for the level.. Used the rule machine to set the push 1 to on, and held to start increasing brightness, push 2 to turn off light, and lower brightness.. but when it hits 0 it just turns off.. rather it just stop lowering the brightness at like level 5.. Tried a few if/then/else setups, but I think the device is updating hubitat to slow for it to capture when it gets to under 5 brightness.. or my rules just suck LOLOL

Rather disappointed that device listed on the "Compatible Device" list is not fully function out-of-the-box, and requires a workaround to make it function. I specifically ordered the switch based on that list.

Side Note for anyone looking into these switches: I Wanted something that I could just put over the physical switch. While in theory this GoControl Smart Switch does that, it actually does not line up with the screw holes on the physical switch (with the cover plate removed) - The holes in the GoControl switch are two far apart. Perhaps this is a region thing? Bigger light switches outside the US? I don't know, So ended up having to use the double-sided tap to just stick it on the cover plate. better than having to remove the physical switch, lol.