Migration to new hub

I bought the new (integrated) hub to replace my early version with dongles.

I backed up the config and loaded it into the new hub. Devices show and all appears as expected except that nothing works.

Please advise

Now start moving the devices themselves.

Start with the closest Zigbee device. Put the hub into pairing then do the pairing dance with the device. The hub will tell you it found a previously paired device and just drop it right in to all your automations. Repeat.

When your success at Zigbee allows you to feel confident, it's time to try a ZWave device. They do NOT come across as easily. :slight_smile:

There's a technique that involves changing the DNI of a device in the Hub then Joining a ZWave device. It will get a brand new DNI and you can change it to be the old DNI.

3 Likes

I have o say that this is an absolute bloody shambles.

What is the purpose of a backup if you can't move to a different hub??

I don't use zigbee. I got one zwave plug to migrate, but now when I try to do other devices I get

"Found Z-Wave Device with id 09

Initializing"

forever.

Assume this wasn't resolved? I bought a DOA hubitat on black Friday and the zigbee radio was broken. They are sending a new unit but I really don't want to re-pair my devices!! I'd rather just start over with home assistant if I'm going to do that again.

It wasn't. Which is why I no longer use Hubitat and have made sure that folks to whom I recommended it know the problems too.

FWIW, if you have a C5 or newer hub, or a C3/C4 with the zwave.me dongle, you can use Hub Protect to seamlessly migrate a zwave network to a C5 or newer hub.

I’ve migrated my zwave network twice: from a C5 to a C7, and from a C7 to a C7. It was effortless …

2 Likes

You can move the backup to a different hub. It backs up the rules, apps, but not the Zwave radio itself. With some effort, you can restore all your devices onto the new hub. I just did this a while back and it was a bit of a pain, but mostly just because I had to run around the house and try to remember how to put everything into pairing mode.

The hub protect service can do the migration like aaiyar mentioned above. And it isn't like you will be doing migrations that often. This seems like a very odd reason to badmouth Hubitat.

2 Likes

How far did you get before noticing the Zigbee was broken? Like do you have lots of rules, and dozens of Zwave devices? If you have just a few rules or devices, it might be worth just starting again fresh, or just export/import any rules you may have.

If you have Zigbee stuff, it is very easy to get these back into the hub without much effort. Zwave can be a bit more painful, but is do-able.

Talk about pain and having to pair things over and over again! I must have installed HA a half-dozen times. With all that command line crap and something like putting one comma in the wrong place irreversibly corrupted the whole system. That abomination of a system was what made me look at Hubitat. It was one of the most frustrating experiences ever.

2 Likes

I don't have a single zigbee device paired and 0 rules configured. I literally got 4 dimmers and a thermostat paired with the google app integration and that's it at this point. I do have some zigbee movable plugs but haven't even tried because radio immediately goes offline after a fresh reboot. They must have some bad units with this issue or they wouldn't have issued a new device without a single troubleshooting step.

That doesn't necessarily mean they have a bad batch of hubs. They probably are just being proactive, and not wanting to drag things out like some companies do. With certain symptoms, it probably is faster and easier to just send a new hub.

I would just start fresh with so few devices.

If you are not comfortable doing a migration by hand, consider the Hub Protect service which warranties the hub, and gives you cloud backups as well as a migration service. Hub Protect | Hubitat Elevation®

3 Likes

I just finished my migration from C5 to C7 using @bravenel 's Migrating a Z-Wave Network as the guide. (Hat tip to @JonhRob for his simple breakdown Migrating a Z-Wave Network - #102 by JohnRob)

After a false start (hint: you need to change ALL of the DNI's. You can't "test" the process with one device), it went very smoothly.

25 Zwave devices took me a couple of hours to migrate over. Having a laptop to walk around the house made this a lot easier than running up and down stairs to get to a desktop.

Felt tedious to start and after a few devices built up some (false) confidence, it moved very quickly. That said, I sure do wish there were a better way that didn't cost $120 to move to my new $100 C7 impulse buy.

2 Likes

Download the Hubitat app