Migrating from SmartThings hub to Hubitat

Hi So I pulled the trigger and purchased the C8 hub along with a C7 that I had. So at this point I'm ready and in the process of moving stuff over from my SmartThings Hub to Hubitat hubs. I would like to have some of the items that I moved over to Hubitat also mirror and be usable in my SmartThings App I did try Maker API and Mira but had issue where it would show up in the SmartThings app but when I changed the state of the sensor it would not change in SmartThings until I manually refreshed the icon in SmartThings then it would change the state of the sensor in SmartThings , I removed everything several times and reinstalled several times with the same results. I will give it another try to clear everything and start fresh but if this does not work is there an alternative app here that will give me the same results that I'm looking to do?
Thanks Looking forward to get things going in Hubitat.

1 Like

There is a user app (haven't used it for a while) called HubConnect.
Have you tried it?
People have used it to 'mesh' the 2 hubs together but with all the changes that have gone on with ST it may not work anymore.
Others may be able to advise.
Good luck.

EDIT: Found it. Looks like it no longer works!!

Ok Thanks. I liked Mira was simple set up but for some reason wont work for me.

Maybe look at: [RELEASE] HubiThings Replica

I am pretty happy with Mira :

I know I like it too but for what ever reason I cant get it working properly as I explained in first post.

Probably @coreystup can give you some troubleshooting advice.

Thank You Yes i might have to give it a try do you know if it still working ok with the ST changes or does that matter?

Thanks kkossev he is trying to help but I still have no success not sure what is causing it to not fully communicate with each other.

It's a fairly new app but from what I gather it seems to be working well.

thanks been trying to install it but hung up on creating an API gives errors SmartThings API ERROR: groovyx.net.http.ResponseParseException: status code: 403, reason phrase: Forbidden

With the deprecation of Groovy on ST, I was under the impression Hub Connect would stop working.
@csteele would know for sure

Hub Connect did indeed stop working on ST when they shut down groovy.

ok thanks guess im out of luck for now to connect hubs

So does Hubithing work both ways with SmartThings and Hubitat I did get it working but only see thing from SmartThings on the Hubitat hub but nothing on the SmartThings app.

My understanding is that it is a two-way setup. Got rid of everything ST a few years ago so can’t test it myself.

You'll probably want to switch to HubiThings Replica.

Thanks that what I set up and can see things on the SmartThings up to 30 but not sure how to go the other way to see Hubitat things on the SmartThings Hub. Is there a setting to do what I'm trying?

The 30 device limit is per OAuth. You can add additional OAuth apps if you have more devices. I have four OAuths authorized myself, but they were created before the limit was raised from 20 to 30 devices per OAuth.

You can mirror Hubitat→SmartThings by authorizing Hubitat devices in advanced configuration, which can be enabled immediately under the OAuth That will take you to this screen, where you can "mirror" those devices to any available SmartThings virtual devices.


If you need assistance, I suggest posting in the HubiThings Replica thread. The developer and others are there to lend their assistance.

It's worth noting that HubiThings was developed with an emphasis on mirroring SmartThings devices to Hubitat. If you're going to do a lot of complex mirroring in the opposite direction, you might want to consider using Mira, which was developed for that purpose. Note that you can easily use both if that suits your needs.

Hope this helps.

1 Like

Thank you, I tried Mira and would really like to use it perfect for what I want to do but for the life of me trying for a few days now I can not get them to connect proper my device shows up on SmartThings ok connected but I have to do a manual refresh to change the state of the device tried multiple time with no success this is why I decided to move on and try something else.

1 Like