Maker API issues after latest update

My hub came with platform 2.2.9.146 installed, it was upgraded twice to 2.3.1.130 and then 2.3.1.132, At least those are the 3 versions visible in diagnostic tool when rolling back.

I can confirm HACS-Hubitat setup worked after restarting HA when HE is running 2.2.9.146 but fails with 2.3.1.xxx.

you need to have an address in the URL to POST device events. Example. h t tp://someIPaddress:2222"

check POST location events ON.

The event posting was working despite the config error. I just edited the log content I posted a) to remove the ip address and b) because this community platform complained about having real links in the content.

Is there a way to download / apply a specific version of the platform. Seems I could upgrade to latest 2.3.0.x and it would still be OK.

Found the bug in 2.3.1, fix coming in the next 2.3.1 iteration.

Yes, you can download it using an endpoint http://hubs.ip.address.here/hub/advanced/downloadPlatform/230

6 Likes

Weird thing is I did not encounter it in versions up to .130

1 Like

That's when it was introduced... I'm surprised it didn't manifest sooner.

3 Likes

When can we expect to get the fix for it?
/Mattias

No - I mean how can I download and use 2.3.0.x since the check for updates option only finds the latest version and my hub is new so doesn't have a 2.3.0.x version to roll back. Can I not download a specific version of the platform from hubitat.com or github ?

I get a 404 when using /hub/advanced/downloadPlatform/230

Did you not see this response to your earlier post?

No. Also, http://hubs.ip.address.here/hub/advanced/downloadPlatform/230 endpoint (and similar ones for earlier versions) is available in 2.3.1 only. In 2.3.0, similar endpoints are slightly different, and none of them allow downloading latest 2.3.0.

1 Like

Should be fixed in 2.3.1.133, available just now.

5 Likes

Um,

Release 2.3.1.133 Available

3 Likes

Fixed.

4 Likes

Just FYI for anyone else who reads this thread. I rolled forward to 2.3.1.130, did the download of the 230 platform with /hub/advanced/downloadPlatform/230 which made it available in the list to choose in roll-back.

And just as I came back here to say that, I see 2.3.1.133 is ready. Oh well it's all good learning.

2 Likes

EDIT: Issue seems to be with my Node Red, working through it, all good with 2.3.1.133 thanks for the support!

2.3.1.133 Fixed my Home Assistant errors, did not fix my Node Red errors using "node-red-contrib-hubitat" palette? I tried creating an new access token, then I created another instance of Maker API, both same access error:

groovy.lang.MissingMethodException: No signature of method: java.lang.String.call() is applicable for argument types: (com.hubitat.hub.domain.Location, java.lang.String) values: [MurnControl, eventHandler]
Possible solutions: wait(), any(), trim(), collect(), size(), split() on line 225 (method updated)

4 Likes

Me either - I am still on 2.3.1.130 on all my hubs and both NR & HA (and NR within HA!) all appear to be running and responsive... little reluctant to update but since there is a known bug.....

:man_shrugging:

1 Like

Could you please PM me your hub's id? I'll take a look at the engineering logs.
The code in reported line is exactly what .133 is supposed to fix, so this is a bit puzzling.

2 Likes

I just updated my hubs and everything is working.

3 Likes

Glad to hear. Rebooting right now. I actually made a workaround for my HACS setup using MQTT.

1 Like

Download the Hubitat app