Maker API cloud API returns "No response from hub"

Hi,
Calling any of the cloud URLs from my PC returns "No response from hub".
Local URLs work fine.
I checked "Allow access via remote/cloud" checkbox on Maker API.
I verified I can ping cloud.hubitat.com.
Also tried to remove and re-install Maker API without success.
Logs view doesnt show anything when I enter a cloud URL on browser.

Versions I am using:
Platform: 2.3.1.139
Hardware: Rev C-7

Thanks,
Avi

Could you need to select this option in the Maker API setup?

I just tested it. Works ok. So this issue appears specific to your HE. Can you confirm that your C-7 is registered on Hubitat's cloud as described in the documentation (link attached below)?

https://docs.hubitat.com/index.php?title=Registration_and_setup

To check if your hub is registered on Hubitat's cloud, go to "my.hubitat.com" and login. Then select "Registered Hubs". It will give you a list of your registered hubs - like this:

2 Likes

Ignore my post then, well spotted @aaiyar, well, well done on reading the OP more closely than me.... :slight_smile:

2 Likes

No worries @sburke781 , happens to everyone.

@aaiyar you probably nailed it.
I am trying to find my hub, and I get into an endless loop.
I've registered the hub in the past, and later on, changed the hub's IP address and made it static.
Since then, the hub no longer apears as registered.
I verified both my laptop on the hub are on the same LAN and also rebooted the hub.
Should I factory reset the hub? Any other option?

Tagging @support

NO!!

Make sure your hub is not blocked inadvertently by some FW rule first. And wait for @bobbyD second!

2 Likes

I would say, release the static IP and allow your DHCP server to assign a new IP to see if that resolves the problem.

4 Likes

Spot on! Thanks a lot, @bobbyD for solving it.

2 Likes

Download the Hubitat app