Major Lag

I am having quite the odd issue. The other day all of my automations starting delaying. Walking down hallways, motion would take up to 5 seconds. Turning on and off lights that trigger other actions, were delayed. Now the delays are often up to a minute or more. Bathroom motion lights take up to a minute to work, hallway motion takes forever. When I turn one light on, the other should turn on, now its delayed. If I ask Alexa to turn something on or off, its delayed by a large amount of time also.

I am looking at the logs and it is picking up all commands, motion etc, as soon as it happens.
Not sure where to start with something like this!

Reboot hub, Install Hub information driver so that you can monitor CPU and Memory

1 Like

I’ve repeatedly had this same problem and put in several posts, but the only advice I’ve ever gotten was to reboot the hub (with some suggesting to do this routinely). But what I’ve never seen was a cause for this or how to prevent it (other than periodically rebooting the hub).

Are you monitoring memory levels?

1 Like

Pull up the Zigbee and Zwave logs via settings menu and see if a device is spamming the hub frequently.

1 Like

What hub version are. you on? I'm seeing this issue since I migrated from the C7 to C8... it comes and goes on its own. Nothing apparent spamming the z-wave mesh, and it worked fine pre-migration.

I am not. How do I do that and what should I be looking out for?

BTW, it seems lags often happen late at night, (11-12ish) so I’m not going to go back to my computer to start looking at logs then. Can I go look at this the next day and still see the relevant values?

The other thing I’ve noticed is that often if I get a big delay and then try the same switch right after it finally came on/went off it responds almost instantly. Likewise, it seems switches I haven’t used for a while may take longer when first used again then seem to respond almost instantly. This makes me think there may be some kind of cache or indexing where seldom used ones get pushed down to the bottom. Is that so?

I’m on .117. I have a C-7. I won’t start using the C-8 until next week as it is going to be my “surprise” b-day gift next week.


When are your backups being done?

Install @thebearmay 's Hub Information Driver 3.0 and create a tile with the HTML attribute. This will give you the following information on your dashboard

When it starts getting sluggish you can note the free memory... You can also graph it using @bptworld 's Quick Chart... Both these are available in HPM... Now if it's a low memory issue you can start tracking what you have installed depleting it or even simply make a rule that if memory falls below, lets say 120k that the hub will reboot automatically at 3:am or so so nothing is noticed.

1 Like

I'll just add that this does not quite tally with the OP experience... Could be completely different causes at play... Still interesting conversation and useful to capture the experience and any solutions...

Where is this at? I do not seem to see it in there.

I am running C-5 with Platform version: That is the most recent update. As the days go on, everything is getting slower and slower. I can see all functions trigger immediately, but the delay for it to actually function is wild.

Settings \ Zwave Details and click Zwave Logs button

Settings \ Zigbee Details and click Zigbee Logging button

I got the Hub Info Driver V3 installed, set up a virtual device with it as the "type" and added the virtual device to a dashboard. When I went to add this virtual device to my dashboard I don't see HTML as a template. So I'm lost when you say to create a tile with the HTML attribute.

Needs to be turned on..

I am also suffering from the same issue, however I see this with a couple of wifi devices. Your description is almost identical, there seems to be a massive (~5 sec) delay but then following activations are almost instant.

This has been making troubleshooting problematic as you only get 1 shot when you want to test it.

I am logging CPU/Mem in Grafana via Prometheus and haven't yet found a correlation to hub resources and the lag. This only started once I upgraded to the 2.3.5.x train. I was previously on the 2.3.4.x train and hadn't observed this issue at all.

I'll keep testing to try and get some concrete data, but it will take some time.

My layout is a little bit different than yours, but I turn it on as well as Remove unused attributes and Allow Hub to be shutdown or rebooted as I saw you had those turned on. (See screenshot below).

I then clicked Save Preferences, and after I saw the screen flash, letting me know that was done, I clicked Save Device and waited for the screen to refresh.

I then went back to my dashboard and clicked the "+" in the upper right corner to add a tile and picked the Hub Info again, but there is still no HTML template to pick.

BTW, I thought it might be an attribute, but I don't see HTML listed there either:

If it is a link I'm not sure what to put in for the values:

So I'm clearly missing something, and would appreciate some more instructions on how to set this up.

Reboot the hub and see if it shows up (you did click save after checking everything right?

Rebooting gave me a lot more attributes. But Free Men and CPU Load (which I assume is what you suggest I monitor) is showing zeros.

It's been over 20 minutes and I refreshed the dashboard page but the values aren't updating at all.

By clicking Refresh in the device itself I got most, but not of the values to come through. For some reason Free Mem, CPU Load% and Temperature are all nulls.

From inside the device:

On my dashboard once I click refresh inside the device: