Lutron Pico Button Limitation - Released Events

I have a very strange limitation to report and it wasn't until I pulled my hair out trying to get this to work that I finally realized that it was the Pico that was causing my problem.

I was trying to set up rules in RM to simulate the "Start Raising/Lowering" and "Stop Changing" commands for a dimmer that doesn't support it. The first one I set up using buttons 2 and 4. When the button is pushed it starts a repeating rule that raises/lowers the dimmer by 10% every second. When the button is released it cancels the repeat. It worked perfectly. And I was quite happy with myself.

Then I went to set up the same set of rules for another dimmer using buttons 1 and 5 on the same Pico. But it wouldn't work. When trying to go from 10 to 80%, whenever I let go of the button it would just keep changing. In fact, when I would then hit the opposite button, they would begin competing and the level would go from 100 to 90 to 100 to 90 to 80 to 90 to 100. I would have to rehit both button briefly and then it would work again. I tried everything I could think of. I wrote over-arching rules for stopping with multiple triggers. I had actions set up in RM that were triggered and stopped. I finally tried an individual rule for every action, 8 rules in total. I was about to give up when I happened to notice the lights on the Pico. The whole time i was setting it up, I was looking up at the lights in the room or at the device page on HE....NOT at the PICO in my hand!!!

That's when I realized the lights were different for buttons 1 and 5 than with 2 and 4. Buttons 2 and 4 work perfectly. No matter how long you hold them, they will never change until you release them. You can hold them for 30 seconds and you'll still get a released event. However, even using the Fast Pico driver, when you hold down buttons 1, 3 or 5, after 5 seconds the light starts flashing on the PIco and it NEVER reports released. I have tried this with multiple Picos configured in Fast-Pico mode.

Here are the logs from the Pico in question:

dev:8122019-01-05 07:38:29.983 pm infoBathroom Pico button 2 was released
dev:8122019-01-05 07:38:21.400 pm infoBathroom Pico button 2 was pushed
dev:8122019-01-05 07:38:10.040 pm infoBathroom Pico button 3 was pushed
dev:8122019-01-05 07:37:59.611 pm infoBathroom Pico button 1 was pushed
dev:8122019-01-05 07:37:48.652 pm infoBathroom Pico button 5 was pushed
dev:8122019-01-05 07:36:44.638 pm infoBathroom Pico button 1 was pushed
dev:8122019-01-05 07:36:43.264 pm infoBathroom Pico button 2 was released
dev:8122019-01-05 07:36:43.144 pm infoBathroom Pico button 2 was pushed

You can clearly see that buttons 1, 3 and 5 have no "released" events. And no, I did not edit the logs. I'll get a screenshot if someone doesn't believe me. Further testing showed that the max time I was able to get to hold buttons 1, 3 and 5 was 6 seconds. After that, I would not get a released event.

So, I decided to try with a Pico in regualr pico mode, and the same things happens.

dev:3732019-01-05 07:45:26.244 pm infoOffice Pico button 1 was held
dev:3732019-01-05 07:45:13.525 pm infoOffice Pico button 5 was held
dev:3732019-01-05 07:44:29.984 pm infoOffice Pico button 5 was released
dev:3732019-01-05 07:44:29.066 pm infoOffice Pico button 5 was held

As you can see, if you hold buttons 1 or 5 for more than 6 seconds, you do not get a released event. EVER. And this does appear to be a hardware limitation as it's not sending any message when you release the button. In fact, the light doesn't even go off in the case of button 1.

So, clearly, there is a hardware limitation of 5-6 seconds for buttons 1, 3 and 5 being held down before the remote will not report a released even when the button is released. I believe this has to do with the way that the Pico is programmed/modified within the lutron system. You can modify the level a button sets a device without having a controller from within the pico itself (this is within a lutron system, not integrated with HE).

Someone the other day was posting that HE can use the pico "better than Lutron can". Well, here's an area where it clearly gets you into trouble eventually in HE. :grin:

Now, if I was able to repeat actions with values less than a second (functionality removed from RM) then I wouldn't have to hold it so long.

I have a 5-button Pico using the "fast" driver and was able to replicate your findings: if the top, bottom, or middle button are held for more than 5 or so seconds (the time at which the Pico remote's LED begins to flash again), no "released" event is reported. The raise/lower (dimming) buttons are fine. I don't see anything in the telnet logs, so this is likely indeed a Lutron limitation, and I'm not sure what Hubitat could do about it.

That being said, I'm sure you're aware of several workarounds. You could step the brightness down by 10% or whatever you want with a press rather than simulating continuous dimming while held (not as sexy, but it worked; I'm guessing this is exactly what you were trying to avoid). Or, you could use the buttons like Lutron intended, with the raise/lower buttons being used for that purpose and the events reported as expected. (I assume the middle buttons would still work this way on a 4-button remote where the middle are labeled for raise/lower; I'm not sure if this would be different on the 4-butto ones that are labeled for scenes or separate lights.) Finally, you could write a custom app and do whatever you want. :slight_smile: Maybe I could expand my Dimmer Button Controller app to simulate this behavior on lights that don't have it (but my first prority is finding some way to work around the bug on Hue Bridge bulbs that do claim to support this).

Yeah...I know all of that. I wasn't asking for help. Just trying to help someone else avoid the massive headache I got before I realized this is what was screwing me up. :smiley:

This is an interesting discovery! I guess God (Lutron) intended 2 and 4 to be raise/lower buttons, no matter how much we try to get around it. We'll add this to the documentation.

1 Like

I noticed this recently too, but only button 2/4 are intended for raise and lower a load. I can understand why Lutron designed it this way.