Lutron Integration / Connection Help

Hi, I'm hoping that you all can help me find something i might have missed in getting my new-to-me Lutron Hub integrated into Hubitat.

I have the Lutron Pro Hub (L-BDGPRO2) on the same subnet as my primary Hubitat hub that I am trying to integrate with. I followed the instructions in the documentation.

The hub is a C-7 running current the current version ( They are on different switches but i don't think that's my issue, they're in the same subnet and my other hub is communicating with the main one across the network without issue. All hubs (Hubitat and Lutron) are set to DHCP with router reservations for them. Wired ethernet connections are also in place for all hubs with a PFSense firewall.

I am running pihole and adguard for DNS but as a local integration, i wouldn't think this is the culprit? In any case, DNS logs don't show any traffic when i enable or disable telnet on the Lutron Hub so there's been nothing to block.

What's interesting is that after adding the Lutron app, per the instructions a device was created fir 'Lutron Telnet' which has only ever shown "offline". This device wasn't mentioned in the documentation so i was a bit surprised. Probably unrelated to anything.

The device i'm trying to integrate is a Caseta dimmer (to start). I can control it via the Lutron app and a device was created for it after i created the Lutron Integrator app but i don't have any control over the device via Hubitat. The Lutron also shows no 'Connections' in the app.

I confirmed that Telnet was enabled on the hub, etc.

Is there any troubleshooting that I haven't tried that might help pin this down? I'm at my wits end...

Thanks for any help you can provide.

Make sure that device has the correct IP address for the Lutron bridge should be the first step

Make sure the Lutron Caseta SmartBridge Pro2 is using the default username (lutron) and password (integration).

You can try connecting directly to the SmartBridge Pro by using any Telnet client, like PuTTY, from your desktop or laptop computer. This way, you will at least know for sure that the SmartBridge Pro is responding to Telnet connection requests.

It's not a RA2 hub. Am i still supposed to be able to Telnet into it?

I did verify the IP address multiple times. Even tried different lease IP and rebooted.

I think the next thing to try to is to challenge my assumptions and put the Lutron Hub and the primary Hubitat on the same switch.

I'll report back but thanks for the responses thus far.

Yes, that is the only way the Hubitat hub currently can communicate with Lutron controllers. That is why the Caseta SmartBridge PRO2 is required, as it supports Telnet whereas the non-pro version does not. Flip your SmartBridge over and verify that you have the correct model number. Also, make sure that the Telnet feature is enabled on the SmartBridge.

1 Like

This is an excellent point, and easy to overlook.

1 Like

It's definitely the PRO2 hub and i found and verified that the Telnet option was checked in the Lutron app.

SO i guess we can call this closed with prejudice.

Running out of options, i moved the Lutron hub onto the same switch as the main Hubitat hub that I was trying to integrate it with.... It connected right away and i was able to affirm control of the Lutron dimmer through the hub. I'm kind of confused about how that made a difference as the two devices were definitely in the same subnet so it should all have been Layer 2 traffic and work transparently as intended.

Thanks to all who took the time to offer suggestions and I appreciate your patience. I may do some more troubleshooting with the network question but i think that's outside of the scope of either the Hubitat or Lutron hubs.

1 Like

Glad to hear you were able to get it talking.

It's not a mokerlink switch is it? That said, for testing purposes move the lurtron bridge back to the other switch, go into settings>>network settings>>network test and use the ping host option to try and ping the lutron hub... If it fails, check your cable. (also set a static ip on the lutron bridge)