Lutron bugs

The Lutron Intergrator messed up and I had to reinstall it. Using the list entry method, when adding all my Picos back in, I made a typo and entered the id number for one incorrectly. Trying to fix that revealed a few things that seem counter-intuitive.

First, resaving the list will regenerate ALL Pico devices.

Second, it seems that adding individual Picos don't combine or modify with the list - it resaves the new one exactly as I typed it originally. That could be because I'm trying to add the same one but with the correct id. (I've deleted it from the device list before adding it again, and tried editing it on the device page under name and in the device network id.)

Third, when I switched to the individual entry mode, the option to switch back isn't presented.

Seems like to get the one Pico working, I'll have to delete and readd them all yet again, but I'll hold off on that in case you need any screenshots or log entries. (Or hopefully direction on what I'm doing wrong or a hotfix.)

The one I'm having issues with is controlPicoGarage, which is entered as I'd 12 but should be 17. It shows under the app details:

file .... textarea ...

p,18,controlPicoMBedroom q,19,controlPicoMBedroomFan

[Note two commas with #3, but it didn't seem to have any problem with that.]

lutID1 .... text ... 17
lutDev1 .... text .... controlPicoGarage2
lutType1 ... enum .... p
lutDev2 .... text
lutID2 .... text
lutType2 .... enum ... p
(And lutDev3 etc blank except enum.)

For devices it has:

{11=Ra2P-11-682, 12=Ra2P-12-682, 14=Ra2P-14-682, 15=Ra2P-15-682, 16=Ra2P-16-682, 18=Ra2P-18-682, 19=Ra2Q-19-682, 2=Ra2P-2-682, 3=Ra2P-3-682, 4=Ra2P-4-682, 5=Ra2P-5-682, 6=Ra2P-6-682, 7=Ra2P-7-682, 8=Ra2Q-8-682, 9=Ra2P-9-682, 10=Ra2P-10-682}

No "controlPicoGarage2" appears in devices.

A few things:

If you screw up a device like you did, delete the device from the Devices page. Then correct your list, and hit Done.

I'm not sure what you mean by this. It does not create new devices if a device already exists. So if you delete the device that is in error, then hitting Done should create that device (since it won't find it already existing).

It did add the devices a second time when I tried that, but to try again, I need to be able to get back to the list view. The option box to change entry methods isn't available.

Are you saying that it created duplicate devices?

Now that you mention it, they may not have been true duplocates because I had changed them from Fast Pico. Same name, same Lutron id. Tonight, I'll see if I can replicate what I did.