Looking for driver for Tuya Zigbee 3.0 (OW-ZPS2)

I recently purchased some Tuya Zigbee 3.0 motion sensors, but unfortunately, even though they paired well with the hub, I couldn’t find a driver that report motion with them. I tried the Generic Zigbee Motion and the (No Temp) versions but neither worked unfortunately.

I wasn’t able to find a working community driver yet. (Tried the “TS0202 RH3040 Zigbee” and “Konke ZigBee motion sensor” without success). Does anyone have one that works with Hubitat?

This is a link to the device on AliExpress.

In case it might help, when It paired, I got the following from the logs:

I think there is a zigbee device driver that you could use to sniff and decode the packets for motion active and inactive

I have heard of external devices to do this, but I am not aware of anything within Hubitat. Is this something you have used?

I think it was just called device, and then turn on all the logging, it just showed the data package

1 Like

@mike.maxwell would be the one to ask...

1 Like

Ah! I think that will give the fingerprint, I think - Will see if it reports anything else…

Let me know I think I have a driver I could adapt

1 Like

Yeah, load the generic motion driver, enable debug logging, activate motion, post the logs, wait for inactive, post the logs, don't really need a sniffer to see what its doing...

4 Likes

That's what I was alluding to

2 Likes

Sounds good! First thing I did was re-paired it - There was nothing under Data in the device page.

Now there is:

And from the logs when it paired again:


I turned on debug logging but unfortunately, nothing comes up in the logs when motion is triggered…

How long have you left it before trying to trigger motion

2 Likes

I would say somewhere around 2-3 minutes. It lights up when motion is triggered.

And there isn't anything extra in the logs now?

Not yet. But I switched to the Generic Zigbee Motion (No Temp). Will try with the “Device” driver.

At simple driver with shouls show every thing

ArrayList<String> parse(String description) {
log.debug $description
}

It needs to be the motion driver, be sure it's awake and hit configure...
It needs to bind to the ias cluster (0x0500)

2 Likes

Seems to work with the Motion driver! It now shows active.

Thanks all for your help with this!

Don’t think this is required anymore as it now seems to work, but just in case:

2 Likes

This is the thread for the driver I use.
Works great for my motion sensors of this design.

2 Likes

Thanks! In the end, I found that I had 2 issues:

  1. The device hadn’t paired correctly (I should have seen that, but missed it…)
  2. Once it was paired correctly, the driver I was using didn’t work correctly.

I’ll try the Konke driver again at some point soon.

1 Like

I paired a couple of devices branded "Nedis" with HE. According to Nedis support the devices are essentially Tuya inside. Though the generic driver did work, I did not get correct battery levels with it, but it works with the Konke driver. No idea why.

The Konke driver also has an option to customize the number of seconds passed before the device is returned to an inactive state. This setting seems to be missing from the Generic driver. Setting this attribute to 5 seconds (as opposed to the default 20) works as expected, and is an added bonus with the Konke driver. :slight_smile:

Download the Hubitat app