Lock Code Manager

Been using Lock Code Manager for my Kwikset door lock. It has always worked ok. A couple months ago I added a user/code with no problems. The other day I noticed one of my other codes no longer worked. Looked at device and that code no longer existed. I have tried to add it back in with no luck. Lock code manager just says job pending. I then just tried to change the existing code and it says same thing. Never gets updated or changed or added. I've tried hitting configure, refresh, nothing works.

Any ideas? The code that is missing is my Wife's and that's not good...

Only a guess but maybe change the batteries if you haven't done so already?

Yep, tried that first thing.

1 Like

Is this Zigbee or Z-Wave? Also what do the logs say when you are trying to change the code? I seem to remember having a similar issue on my Kwikset Zigbee lock - but I think it was the way the app was updating/refreshing in the UI, I can't remember. Am testing now.

It's Zigbee. I enabled logging on the lock. It says duplicate code. But that code doesn't work so I know it's not in the lock.

Just went out and tried it again. This time it worked. But the Lock Code Manager says failed. The device doesn't show the code. So it must be something with the UI update. I'll let it sit for awhile and see if it updates.

Maybe reboot the hub? That might clear some cobwebs out.. Yeah the LCM interface seems a little wonky sometimes. Did you try the UI in a different browser?

Does the code show in the device page (under Current States -> Lock codes)? I initially set up my lock codes from the device page as I had to "sync" the existing codes with what LCM had for users.

1 Like

No it doesn't show up in the device page. That's what had me concerned.

I tried hub reboot and different browser. No change.

As long as it's working, I guess it's ok. I'm going to check all the codes and make sure they still all work.

If there is some corruption then maybe uninstall the app and reinstall. Codes should still be there. Another favorite albeit scary sounding option is the soft reset which is good for correcting internal DB issues.

1 Like

Now I'm totally confused. I was able to add another code with no problems. But the initial one that quit working doesn't show up.

However, reaching back into the dim recesses of my mind it's possible that the code in question is the master code. Does this not show up anywhere in the device or the LCM? But why it quit working the other day is still a mystery.

At this point since it is all working I'm gonna quit while I'm ahead.

Thanks for all the help.


The master code does not show up - not on mine. I always keep the MC separate anyway and do not use for anything other than configuring/setup.

1 Like

Way back when I first set this up, probably a couple years ago, I really didn't know what I was doing and thus the master code was the only one I was using at the time. I probably need to change it.