Lock Code Manager

Lock Code Manager generated the following:

Any issues?

I just added a code to my lock. What lock are you using? i think that would make a difference. I have a schlage. When are you getting that error?

I tried to delete a user/code from my front door lock.
It's a Kwickset Smartcode 88.

I just checked to see if the code was actually added, and it wasn't there. But no errors while creating. I think there might be something going on with it.

It does appear that Lock Code Manager doesn't really work.
Is anyone really using it?

Yes. I do use it as do many others I’ve seen in the forum. Do you mean to say as of late it isn’t working for you, or that it never has?

I need to know exactly what you clicked when and in what order so that I can try to reproduce this.

Perhaps, I'm just not familiar enough with the LCM. So, I wanted to start over by deleting all the codes for a certain user, and then re-adding them. However, it seems that I couldn't figure out how to do that through LCM.
Step 1: Initial screen:

Then I tried to delete this user and associated codes, and pressing the Done button.
The following is the result:

Even though it says all deleted, the following is the status page:

and Retry failed jobs doesn't clear the queue. (I'm not sure why the jobs failed, but didn't report an error).

a failed job indicates an issue with the hub having difficulty in communicating with the actual lock.
It's best to make sure that the lock is working correctly (try adding and deleting codes, locking and unlocking) from the driver details when this happens, if that's working correctly LCM shouldn't have any problems managing codes for that specific lock.

I will try and execute lock/unlock from the device status page, and make sure that is working.
If not, then I will re-add the lock.

you need to try adding and deleting a code as well.
excluding and re-adding the lock probably won't help, if you're finding that the lock isn't working reliably from the driver page, then it's likely that you will have to add a zwave repeater somewhere near the lock, and then perform a zwave repair.

Mike: Believe it or not, but the lock was working reliably (via program commands), as recently as 2 hours ago. I then started experimenting with LCM, and now, it won't respond to commands from the device page.
I've done a factory reset on it, and I'm going to exclude then include again.
I have a number of devices (supporting beaming, too), between it and the hub.
(The factory reset was important, because that wiped out all codes, as well).

In order to make my life easier for these situations, I enabled a Powerline system in my house. So, in order to move my HE closer to the door, (secure join), I shutdown my HE, then move the Powerline unit (with ethernet and a microusb charger) to the closest outlet. Works fast.

1 Like