Lights Turned On. Rule False


#81

I have broken these down into smaller pistons. However, the lights on this one didn't turn off until 8:15 even though sunrise is at 7:34 less 30 would be 7:04am. And the Undercabinet Lights On in Morning(second one) hasn't turned the lights off yet and it is 8:25am. Both of this pistons have M-F Ristrictions.

image

image


#82

I thought that the update had fixed the issue.


#83

I am not able to reproduce the problem with the light turning on at midnight, at least not after my preliminary investigation of this issue. Is this still an issue?


#84

I will unpause the rule and see what happens.


#85

It did it again on Saturday night. Then I broke the pistons up.


#86

Any idea about the lights not turning off in the above pistons?


#87

As the lights did turn off but later than expected, I would check your location in the hub.
If it is correct I would change it to something else and save.
Then change it back to the correct location and save again.
I know that this sometimes worked for the ST hub but I don't know if HE has had this issue.
Just something to try.


#88

I will give that a try. Thanks!


#89

Hi there.
Yes, my switch turned on at Midnight last night.
I will leave my PC on tonight to get the logs.


#90

Lights still not turning off at sunrise -30. It seems to recognize that 7:04am is the time but doesn't do anything.


image


#91

Can I ask why you are doing a refresh?
Try removing it and see what happens.
You are turning off and refreshing at the same time.
Perhaps the 2 commands running together are causing the issue.


#92

I didn’t have it in before and I it seems that the lights don’t refresh their status very promptly so I put it in to see if it helps. It seems to help as I have a couple of other pistons that do stuff in the evenings and without the refresh they think the lights are on when they are not and vice-versa.


#93

For some reason it isn't seeing the rule as False at 7:04 AM, even though it should. Yes, it sees the time, but it didn't say "... is now False". I will investigate. Can't do that until tomorrow morning.


#94

OK, thanks!


#95

Unable to get logs I'm afraid as my PC decided to shut down last night.
Light came on again at midnight.
It looks like I'm not going to be able to get you logs so I will just use 2 rules and use the days as restrictions.
There is a bug there but i cannot get you relevant logs I'm afraid.
I may try deleting and doing it again but as its happening on 3 separate rules I'm not sure its worth it.


#96

Also, the lights didn't come on at all today. Looks like the rule recognized the time of 4:50am but didn't do anything.

So I turned them on at about 6:46am and they went off at sunrise -30. Weird!


#97

Do you have any restrictions enabled on that rule? I tried to scan up in this thread to find screenshots but none go down far enough to tell.

I'm wondering if restrictions are preventing the rule from being analyzed, which would prevent the rule truth from flipping, which would prevent the actions from running.


#98

Another thought....do you have anything in this rule or a different one that cancels actions of this rule? I think I just realized looking through some of my own rules, that when you cancel actions of another rule, it's canceling delayed actions as desired but it's also canceling "schedHandler" scheduled time condition checks as well. @bravenel is this behavior by design? Or does there need to be some type of filter added to the type of future events that get canceled?


#99

Hi @pcgirl
The print that you have posted.
Where did you get that.
I cannot seem to find that layout anywhere.
I've obviously missed something somewhere.
Thanks.


#100

Click the settings gear inside the rule, then once inside the settings page, click the "events" button at the top.