Lights aren't dimming


#1

I have a few different rules set up for dimming my lights and none of them work. So, to isolate the issue, I created this very simple rule (screenshot below), to confirm that the light is not dimming as it should.

The virtual switch flips my light on but it isn't dimming.

What am I doing wrong?


#2

I’ve never set up an auto fade like this, but try setting ON for the light, instead of Dim 100


#3

Your Dim to 100 is fine. What type of device is "Reading Lamp"?

Have you tried putting a delay on the beginning of the fade? My guess is that it is scheduling the fade and putting the lamp to 100% at the same time. If you delay the fade to start by 1 second it would allow the lamp to get to 100%.

Or you could try setting the lamp to 100% manually and remove from the rule and try just the fade in the rule to see if it works. That will confirm whether the problem is the dim to 100 or the fade.


#4

I have it set to Dim 100 when it first turns on because I usually set it low before bed, so if I have it just set to ON it turns back to the previous low dim setting.

It's a Hue white bulb, it can dim to different levels without any issue. I've never tried having it fade over time before though.

My original rule had a delay of 10 minutes which didn't work either, so I don't think that's the cause.

I tried what you suggested—turning the lamp on manually and having just the fade command. Still no luck.

Any other ideas?


#5

This might not be a feature available to the Hue Integration since the commands aren't the same.


#6

Since it is fading over time every 10 seconds, I assumed it was sending a new Dim command at each interval, rather than a single "constant fade" command. Is there another command that would achieve the same effect or do I have to manually set a delay, new dim setting, delay, etc? That seems... tedious.


#7

I can confirm I have never gotten fade over time to work, at least with a hue bulb connected to the hue bridge connected to Hubitat. I assume just not supported.

I haven't tried this at all, but as a thought maybe a repeat action?


#8

I haven't been able to get fade over time to work with Hue bulbs on the Hue bridge connected to HE.

But I have gotten it to transition between scenes. I haven't tried it with transitioning between a scene that's 100% and one that's dimmed, but it might be worth looking at. I have it transitioning between a scene with one temperature to a scene with a different temperature.


#9

This appears to work


#10

Yep, that did it. Very cool way of tackling the problem, I've only used RM for some fairly simple rules, so this was a cool way of trying a few action sequences I hadn't tried before.

Thanks for the help guys.


#11

I got fade over time to work by treating a Hue bulb on the Hue bridge as both a switch (to ask if it was on) and a dimmer. I was fading from 0 to 100, but I assume it would work in reverse.

I found the problem was that if the light was turned off like a switch, the dimmer level remained at 100%. So when I tried to fade it on, it just turned on because it was already at 100%. Setting the dimmer to 0 if the light was off synced it up.