Leviton Z-Wave+ Switches

Can you please send me those instructions?
I didn't get any.

Suggestions? It looks to only be recognizing 1 of my 2 Switches DZ15S. Updated the Dimmer fine.

This thread is a little old but still very valuable.
I just finished installing a new DZ15S switch and I had a lot of trouble getting it to be discovered.
I called Leviton and they were a great help.
What we discovered was that a restart of the HE hub was the fix.
I had tried to run factory reset and the inclusion sequence on the switch but it just would not discover in the app.
Once I restarted the HE hub everything worked perfectly.
Hope this helps someone else who may be struggling with Z-wave and Leviton switches.

1 Like

I personally have found that a factory reset is the key.
A factory reset on this device is accomplished by holding the top of the paddle up, for at least 10 seconds. After that time, the LED should blink alternately between amber and red - that's how you know that it's done a factory reset.
Whereas with most devices just an exclude is enough, here a factory reset is required.

So after going through a number of resets on the DZ15S switch I called Leviton. I have had a ton of Leviton devices for over 20 years. I find on the whole they work very well going back to X10 days. The help desk fellow at Leviton was really helpful. What we discovered was that the HE hub needed to be restarted. Once I did that the DZ15S came on line without issue.
I'm beginning to wonder if this might be an issue in line with the comment that HE can only discover one Z-wave device at a time. Do we need to do a hub restart for each one?
BTW I have the most recent software on my C7 hub plus the most recent software on my DZ15S switches. Hope this helps others.

1 Like

I think he meant on the HUB and not the device which is 14+seconds btw.
All Leviton Smart Devices have the 14secs press and hold.

Download the Hubitat app