Leviton z-wave plus dimmers - firmware update may needed to work with generic smart driver

Continuing the discussion from Rule Help - Persistent light state option with motion controller:

This merits a new topic that I hope others will find useful if they have Levition Plus Z-Wave Dimmers and Switches that don't behave nicely when they transfer them, I suspect there will still be versions for sale that haven't been updated to the new firmware and for those if us who were early adopters we seem to have an additional challenge to get them to work. I still find them a great dimmer/switch ... and when the update is applied the response to a change is lightening fast on a dashboard.

[Rule Help - Persistent light state option with motion controller]

This has solved my problem - the Leviton Z-wave plus dimmers (**Models DZ6HD and DZ1KD ) were being recognized by Hubitat correctly and the Generic Smart Zwave Dimmer was being applied. Unfortunately this didn't work with the Dimmers which were not reporting a physical or digital change, although the device would switch on and off and dim.

I emailed support and got promptly referred to this topic referencing the updated z-wave firmware for these dimmers. I have about 50 of these, which I installed last year using Smartthings generic device drivers. They have always functioned flawlessly and I never saw the need to change the firmware.

Using the generic "non smart" driver I could get them to function but when I tried to modify the custom device handler from Smartthings community it wouldn't work either and I was hoping to be able to use this to set some of the parameters for fade time etc. without using the physical switch.

Using the links provided above I had to download the Z-flash utility from HomeSeer and connected this as a secondary controller to my Hubitat, after installing the driver on a windows 10 PC.

The software found the devices I had transferred and correctly identified the firmware versions and allowed me to update the dimmers. (This is painfully slow - 10 minutes or more per device and it fails if the dimmer is switched during the process). You can set the software to update the same models sequentially and leave it running.

This has solved the problem. The devices are now responding quickly and updating the status within seconds. Just the way it should. The modified Smartthings driver also seems to work but it switches the dimmers to zero when they are switched rather than leaving them at the last l (on the dashboard).

So now I can get on with the rest of the whole house transfer. So far I've had to change a couple of custom divers to support a Z-wave outlet with power management. Things seem to be responding very quickly and the web interface is much better than using a phone/table to configure settings.

Good so far - will update as I make further progress (am updating the remaining firmwares while they are still connected to the Smartthings hub at present).

Reply

Bookmark Share Flag Invite Reply

Tracking

You will see a count of new replies because you posted a reply to this topic.

Suggested Topics

There are 5 unread and 9 new topics remaining, or browse other topics in Automations

1 Like

2 posts were merged into an existing topic: Support of OTA firmware updates for Z-Wave / Z-Wave Plus devices

Download the Hubitat app