Lesson learnt regarding new Scene 1.2

Now that the new v1.1.16 firmware has been released, I've installed it and I've just deleted a couple of my Scenes (v1.0) and recreated them as v1.2. However, I cannot now get them to switch on my dimmer lights involved in the scene. I have tried setting the lights on and recapturing, and I've also tried manually setting the scene settings but neither approach works. The other lights (some relay-based switches and a Hue bulb) all come on correctly but not the dimmers. One is a Qubino Flush Dimmer and the other is an Aeotec Smart Dimmer 6. Both worked perfectly in the old Scene v1.0 :frowning:

Update: If I set the scene transition time to a value (it's not automatically set when creating the scene or capturing settings) then the Aeotec Smart Dimmer is switched on but still no luck with the Qubino Flush Dimmer).

Update 2: Umm, lesson learnt, if you're using custom device drivers, check they properly handle the interfaces required. The Qubino driver I was using only implemented setLevel(int), not setLevel(int, int) which was being used by the new scene. I have adjusted the driver code and all is working now.

1 Like

I'd love to know how to do that since none of my scenes work now using the driver I have for my blinds. Can you give any further details on the changes that were necessary?

It depends on what the issue is with your driver. It may be the same thing. If you open up your "Logs" view and then try activating one of the scenes in question you should see some useful error messages that will help determine what's failing.

[dev:169]( 15:43:46.546:errorgroovy.lang.MissingMethodException: No signature of method: dev1539815906578993760279.setLevel() is applicable for argument types: (java.lang.Integer, java.lang.Long) values: [30, 1] Possible solutions: setLevel(java.lang.Object) (setLevel)

That's the error I get. And I have no clue what any of that means. I guess I'll leave my scenes in webCoRE since that's what I know how to do.

If you look at the device handler code for that device you will see something like this:

def setLevel(level) {

You need to change it to:

def setLevel(level, duration=null) {

That should fix it.

1 Like

SCORE!!! That did it. Thank you SOOO much. You don't even know home much I appreciate that.

1 Like