Kwikset 916 zwave notifications not working (and working)

I have two 916s zwave, one works perfectly and the other doesn’t. They both installed fine (physical and he). The 916 that doesn’t work as intended will not send me notifications of lock/unlock, user unlock.

I did compare the two and see under Device- Data grid one has a device type 3 (one that works perfectly) and the other has a device type 1 (doesn't work exact). I was wondering if that is the issue and how to change it.

I’ve doubled and triple checked notifications, deleted all, deleted 916, reinstalled everything multiple times.

Any help is greatly appreciated!

Can you control this lock from its device page?

Yes I can lock/unlock remote. It also tells me the battery level but I don’t believe it.

I can also add/delete codes from device page.

@bobbyD is there a way to get some eye balls on this thread? I’m new here, so not sure my expectation’s are realistic or not on timing and who would be responding. Thanks!

If one device doesn't work as expected, but another in your system does, then that is indicative of device problem, rather than hub problem. Your device may be running a different firmware. I would try excluding and resetting then reincluding the misbehaving lock.

Thanks for the response! I have tried numerous times. Is there a way to change the device type shown in the attached pic to be the same? Or force it to be same. Pic of both front and back.

I have taken the recommended steps and deleted and reinstalled. "Magically" it worked. Moral of the story, reboot always seems to work (even if needed multiple times). Thanks, closing this out.