Kwikset 910 Z-Wave Lock


#61

Noooooo! While it's well designed hardware, you're stuck in the cloud. I have a gen 2 August with Bridge and have to trigger is with Google Assistant Relay to get any kind of speed and reliability when interfacing with HE. August Z-Wave won't pair with HE. They've done something non-standard and it's currently unsupported. Plus you're then tied to your phone or a kind of crappy keypad that doesn't do well in cold weather (if that's a problem where you live).

Yale and August are both Assa Abloy now. So far their blended lock is just software. Probably will be some nicer options in the new year.


#62

I've had zero issues with my Schlage and Kwikset zwave locks over the past 6 years. No way I would go to an August or other cloud required solution.


#63

I ended up exchanging the Hubitat for new Hubitat and was able to pair 2 out of the 3 locks after several attempts w/each lock. It did take a long time to initialize, more than an hour for each lock, why I don't know.

I was wondering how you set it up to lock or unlock remotely?


#64

I added a tile to one of my dashboards for it. You can control it while very remote via the Cloud Dash, or from your couch via the Local Dash.


#65

Has anyone used the zigbee version instead of Zwave? More or less issues?

I was getting ready to purchase - debating between ZWave vs Zigbee... Just getting started in this home so I don't have any other equipment yet (and I think I'm planning to use Lutron RadioRA2 for lighting).


#66

I have a zigbee Yale lock, and it is less fidgety than the zwave locks I've tested and own.
If you go the zigbee route, do not under any circumstances pair any zigbee bulbs other than Sengled directly to HE.
Every bulb I had in the lab other than sengled eventually parentified the lock and refused to pass any lock commands whatsoever until I unscrewed them...


#67

Yikes! very interesting... thanks for the heads up


#68

Looks like I need to start up this thread again. Been trying to pair my 910 for about an hour. I removed the device from my IRIS system, and followed the directions to do a factory reset of the lock. I have the hub on a looooooong ethernet cable and extension cord reaching all the way to the lock, so the hub is inches from the lock. I put the hub into search mode, I put in the batteries, hit the "A" button once, wait several minutes... and nothing. Then I go back to the computer and hit the "Zwave Exclude" button. It does something or other for 30 seconds. Then I hit the "A" button one more time. Then I start over. Question: I don't understand the Exclude process... am I supposed to do something during that 30 seconds or just wait til it's done?


#69

I can't tell if you're doing an include or an exclude or a factory reset :slight_smile:

Found this antique set of instructions from 2014:

How to perform a factory reset:

Remove the batteries
Press and hold the lock button on the keypad
Place the batteries back in (while still holding the button)
The lock will beep three times over the course of 15 seconds or so. After the 3rd beep release the button.

You can Exclude a variety of ways. Use Iris, use Hubitat, use a handheld, like the ZStick or Minimote. In most cases, a factory reset does the exclude as well.

Lookup the Lock's Conformance Statement at the ZWave Alliance:
https://products.z-wavealliance.org/products/2239/embedpics

It also has the Network Include/Exclude/reset procedures.
https://products.z-wavealliance.org/products/2239/network

It says it supports Beaming, so perhaps CLOSE is not what's needed. It may Exclude or Include/Join in place IF you have a Beaming repeater nearby. Look at the Conformance Statement for an A/C powered switch or outlet nearby.


#70

OHMYGAWD. All the directions I found for reset said to hold the Program Button.
But your instructions worked! Holding the LOCK button instead, waiting for 3 beeps, Put hub in pairing mode, then hit the "A" button once. Came right up!

What a relief. Thank you so much.


#71

Woo the heck Hoo

:slight_smile:


#72

Some of the Kwikset locks definitely use the Program button. I've factory reset mine several times (Mine are 914 and Z-Wave "Plus") and they definitely use the program button. Holding the "lock" button on mine is how you determine the door handing (IE: How the deadbolt knows if it's a left or right facing lock) so you gotta be careful that you find the right instructions for your lock. Within each model (IE: 910, 914, etc) there are like half a dozen or more versions of that model that sometimes have slight differences in how they are paired, programmed, reset, etc.


#73

I just spent the last hour trying to pair my Z-Wave 910. Excluded from ST. Did an exclude from HE for safe measure. Tried to pair it no less than 10 times. It would pair. But not secure. So no communication whatsoever once it did pair. Last resort was getting a long cat5 and holding it literally an inch away from the lock. Paired perfectly first time. Just wanted to chime in and say that seems to be the thing that works.


#74

yep, it's called "Whisper Join". It's an intentional feature of the Lock and the lock manufacturer. The other one you'll bump into is "Beaming Support".


#75

Does the generic driver have a “jammed” status? Our door you have to push until it “clicks” for the lock to fully engage. Been a few times someone has not done that and when we leave ST would notify me the lock was jammed. Didn’t know if HE also reported that as well.


#76

As far as I have seen, the answer is no. My back door has the same issue as you have where you have to push the door for a second to get the lock cylinder to engage properly (it's on my honey-do list to fix, but it's currently at #50 in said list lol).

To get the same sort of "jammed" status, I have a rule that checks if the contact sensor on the door is closed but the lock is unlocked after 1 minute of the door closing and it sends me a notification.

If you look at the events for the lock, you should see it lock but then report unlocked within a few seconds. That's the "jammed" condition.


#77

@nunkistein0 @corerootedxb I have a similar problem - door randomly seems closed but is not quite in the right position, so the lock jams. This usually happens when the door locks as I'm leaving and no one hears the lock forever cycling to try to close.

My question to you: When you say "jammed" are your locks trying repeatedly to lock or are they trying some fixed number of times and giving up? (I've come home after an hour or more and hear the lock cycling.)


#78

Mine will not cycle constantly. It tries to once or twice then just kinda gives up.


#79

Yeah, some locks will give up after a certain number of tries and others never give up (thus killing the batteries). Mine (a Zigbee Yale YRD226) gives up after 3 tries (which I prefer).

I'm not sure what the ones that never give up report back for status (or if they report back at all).


#80

What is the A button?