Keen smart vent level not updating until manually refreshed

I recently connected a Keen Smart Vent to my Hubitat using the built-in 'Keen Home Smart Vent' driver. I can set the level (using both Apps and a Dashboard tile), and the vent adjusts relatively as expected. However, Hubitat does not show the vent level unless I manually run the refresh command.

This is an example of the debug log output for the device. In this case, I changed the level from ~20% to ~60% at ~14:38. No log messages were printed until I manually ran the refresh command.

dev:643 2019-10-09 14:46:40.408 info MySmartVent level was set to 58%
dev:643 2019-10-09 14:46:40.283 info MySmartVent battery is 100%
dev:643 2019-10-09 14:46:40.279 debug descMap:[raw:22E50100010A21002064, dni:22E5, endpoint:01, cluster:0001, size:0A, attrId:0021, encoding:20, command:01, value:64, clusterInt:1, attrInt:33]
dev:643 2019-10-09 14:46:40.274 info MySmartVent is on
dev:643 2019-10-09 14:46:40.270 debug descMap:[raw:22E50100080A00002096, dni:22E5, endpoint:01, cluster:0008, size:0A, attrId:0000, encoding:20, command:01, value:96, clusterInt:8, attrInt:0]
dev:643 2019-10-09 14:46:40.226 debug descMap:[raw:22E50100060A00001001, dni:22E5, endpoint:01, cluster:0006, size:0A, attrId:0000, encoding:10, command:01, value:01, clusterInt:6, attrInt:0]
dev:643 2019-10-09 14:46:38.849 debug refresh...

Any chance you have "Enable descriptionText logging" turned off for the device?

If you go to the device edit page, does "Current States" at the top show the correct values?

Both debug logging and description text logging are enabled.

I had this issue, I ended up removing and rediscovering my vent to fix it.