Kasa Devices Spamming HE

Hi all, I've updated my Kasa Integration app to the latest version using the Package Manager and I noticed that all of the sudden all Kasa devices have been spamming HE with logs.

I've followed the instructions and reduced the 'Event and State' history size but the issue still persists even after clearing the events and rebooting the hub - All the devices had been working as expected before I updated the app so I can't think of anything else here.

Is there a way to rollback the driver via HPM?


If it's the logs that are bothering you look for the field called "Enable description text logging" or similar in preferences and uncheck that. The event logging is separate. But I think your problem is not specifically that.

Thanks for the quick reply, I appreciate that.

I am afraid that option isn't available under preferences like most devices do:

I haven't updated mine to the latest, I think I will try that now and see what happens to me. However I have Cloud Binding disabled, and the device is just a lightbulb, so I might not have the same problems

Edit: Yep. My option to disable text logging has disappeared too :smiley: I have reported this in the app's thread :slight_smile:

I am not too sure what else to do, I've just cleared the events and rebooted the hub again but 27 minutes later I am already getting the same alert and all 4 Kasa devices are on the top of the list:

Don't worry @hpgurgel, I worked through this myself, I'll give you a hand.

To start with, please disable the Energy monitoring Preference Setting for each plug that supports this and restart your HE hub. You can use the Preference Manager built-in app if you have quite a few plugs, otherwise, just adjust them manually.

tagging @djgutheinz in case you are online....

@hpgurgel:

  • When you look at the Device Edit page for one of your plugs, what driver are you using? Is it the EM Plug or the Plug Switch?
  • When you look under the Drivers Code section, does the driver being used appear in the list?
  • Is the driver listed only once on the Drivers Code page? And what is the date / time displayed?

Thanks a lot, it's nice to have other Aussies here who are willing to assist.

I do need the EM functionality as I use that information for some of my rules - By disabling this, would the rules be impacted?

I installed Preference Manager in the past but it never worked well for me so I uninstalled it as it wouldn't list all drivers for me.

They will be temporarily, but it shouldn't be for too long.... all going well.

Don't worry about Pref. Manager, was only a suggestion if you had a lot of plugs, work through them one at a time updating this preference if you need to.

They are all EM Plugs, see details:


I realised that there was a new release '6.5.1' available on HPM so I ran the update - Perhaps Dave has addressed the issue there already?

The current uptime is around 42 minutes and I haven't got the alert yet which is a good sign?

Yes, the driver appears on the list (once only) under drivers code:

So you were seeing the elevated load on the HE hub, did the update and restarted, and now you are not seeing the elevated load any more?

To test, try:

  • Opening the logs page in one browser tab
  • Turning on Debug logging for 30 mins on one of the plug devices, under the Device's Preference Settings
  • Click the refresh command on the same device edit page

That's correct, so far so good.

I've followed your instructions as well to test:

1 Like

That's good to hear, as long as you don't see a flurry of logs spamming your log page, then I expect you will be ok, at least in terms of performance.

Do you happen to use the Hub Information driver at all? It is quite useful in assessing situations like this.

Where do I find that please?

You can install it via Hubitat Package Manager, or see the thread here:

Probably worth getting through your immediate issue without complicating things for now, just may be worth introducing once you are back up and running

Appears to be very useful as you mentioned.

I found this one on HPM:


Is that the correct version?

I tried installing using the link from @thebearmay but it did not work:

Yes, it is very useful.

@thebearmay can probably comment better than me on your error, but GitHub can have issues from time-to-time..... Or the config for a "package" can also be slightly off occassionally.... Like I said, probably one for tomorrow I expect, best to make sure your system is up and running for now.

Sorry, correction, the one above is the one you want from HPM, but the error is still something to follow up

Download the Hubitat app