Just wanted to report on a group corruption

So just had a strange incident where a simple 2.1 group called "Office Lights" containing 2 sengled smart bulbs just stopped responding. I could go to the "device" and try and turn off/on and the switch value changed but the underlying devices did not. I had optimizations off. Events indicated everything was normal.

Haven't made any changes or updates until it stopped working... tried selecting one device or another but that did not work. Removed group and added back in and things started working.

Couple of observations:

  • Group has been around for a while with no changes. I don't use it all that often so don't know when it stopped working.
  • Group is the last one in the child apps list under groups. Not sure if relevant.
  • Before replacing group played around with various settings, nothing worked.
  • I recently had a Z-Wave device die on me which was causing slow downs, replaced and all was well. Don't think this is related but mentioning it anyway.
  • Sometime after that had Zigbee network go offline. safe reboot restarted zigbee but problem eventually returned. A zigbee "device" that I had removed previously reappeared and was set to "device". Removed that and that seems to have worked.
  • Only apps on that hub right now are: Groups and Scenes / Lock Code Manager / Lutron Integrator / Maker API (3 instances) / Zone Motion Controllers

I've had the exact same issues with two group devices for the last 2-3 days (also with Sengled bulbs). My groups are Group 2.1 groups and haven't been changed since they were created. My observations are:

  1. Changes in the group device are not reflected in the individual bulbs in that device
  2. The bulbs are not offline. The bulb devices respond to changes from their device page.
  3. The group device worked for a day after a reboot.
  4. Deleting one of the groups and recreating it allowed the new group to work for one day, And then it stopped working again with exact same symptoms and #1 and #2.
  5. On/off optimization has always been turned off.

Tagging @bravenel

I wonder if it is related to our "heavy" use of Maker API???

1 Like

Try removing all the bulbs from the group and save. (Don't delete the group). Then add the bulbs back after a few minutes. For me, the group device starts working again for a short time.

1 Like

Could be. Although that use hasn't changed dramatically between two weeks and and this weekend.

My Zigbee stack seems a little unstable not sure why. Don't have anything odd except maybe a lightify strip on the edge of my mesh and it's outdoors. It's been there for a long time though.

The only custom driver is the NTP client...

This is for my main hub - my upstairs hub seems to be okay,

Just curious guys, what drivers are you using for the bulbs? I had some problems a few weeks ago with grouped Sengleds. Switched to the appropriate Generic Zigbee drivers, and haven't noticed any problems since.


That's an interesting thought - Sengled Element Color Plus.

Like @aaiyar I've been running with these for a long time..

edit: I don't know what drivers he's using though!!! :grin:


I had been using the Color Plus and Classic drivers for quite some time. I started noticing the group devices were reflecting the on/off commands, but the bulbs themselves were not. Even after playing with the prestaging settings and the group settings, it would still take more than one on command for the bulbs to turn on.


Same as you. Going to try the Generic zigbee drivers now!

1 Like

Okay - cleared out old state variables and changed drivers. So far so good. Everything is working. Will update later today.


Anecdotally things seem a bit faster.. but will have to see over time.


Changed ALL my 15 Sengleds over to generic and restarted my main hub for giggles.

I have 8 recessed RGBW bulbs in my den tied into a Dual Nano relay switch. Was getting 7-10 second response times when physically turning on the switch. Now I seem to be getting around 3-4 second response times. To be fair I just rebooted but things are usually slower to respond after a reboot. Again this is not a formal test and will have to see what happens.

Still interesting though - thanks for the heads up @bjcowles!!!


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.