Issues with Minoston MP21Z plug in socket not receiving events

I bought a pair of Minoston MP21Z single plug-in sockets, One of them is working exactly as expected in a Mirror Me application to control and indicator light. Very reliable.

The second, not so much. It is in the garage and connected to a car-positioning laser. The intent is to have the switch come on when the garage door opens via a garage door sensor), stay on for 2 minutes and shut off. Don't need the laser coming on when I'm just moving about in the garage.

Periodically it works, but not reliably. The garage door sensor works as I also have it tied to an internal light for coming home at night. No problems there.

However, I see no events in the plug-in socket log for the garage sensor activations. I have also set a switch to do a turn off of this socket (and all of the other switch positions work as expected). Again, nothing shows up in the log.

I should note that, while the other plug in the pack came up as a single switch on pairing, this came up as a dual switch (as some have reported) and I used the Generic Device driver trick to remove the Child. Not using the EVA LOGIK Smart Plug- just as the other one is doing.

I could try to re-pair this (no pun intended :smile:), but I might expect the same thing as I did this twice already with the same result.

Any suggestions on how to proceed with this debug are welcome.

(Just noted that 2.2.6 suggests Generic Z-Wave Outlet for this, so I changed since I just got 2.2.6 today, but same behavior)

Cheers.

Just wanted to add an update:

I replaced with another of the same Minoston MP21Z. It worked for about a week, and is now having the same issue. It turned on recently, but not off. The Off was sent, but not in the switch Event Log. I added it as a tile to a Dashboard to see its state. It is now wedged in a "Sending" state.

I've updated to "Generic Z-Wave Plus Outlet" in 2.2.7.119.

If I refresh the Dashboard, the "Sending" clears, and it shows the Device On (which it is). But I can't get the Off to go through.

Even pushing the button on the switch did not work. I unplugged it and that allowed the button to work. Turned it off mechanically. Now can't turn On from Dashboard.

Not sure what to do next. Appreciate any suggestions.

Cheers.

Well, I seem to be a chorus of one on this, but I'll add debug observations in case someone else faces a similar issue and may find this helpful.

It seems as though the culprit may actually be within the Simple Automation Rules App. As I had it set up, the outlet turned On when the garage door sensor detected Open. That seemed to work. Then it would turn off 2 minutes later. That is what seemed to wedge the outlet such that even the mechanical button wouldn't work.

I changed this to turn off when the sensor detected Closed, and this seems quite robust.

So, something about the time delay mode seems to be interacting badly with this device. At least that's how it's looking so far.

I also note that, in both cases, the App Rule sends an Anti-Turn On and not a Turn Off. If I configured the Off as a separate rule (Turn Off when Sensor detects Closed), it sends an actual Turn Off. Not sure if this is part of the issue.

Cheers.

Someone else had a similar problem, and it was due to using the wrong driver.

Thanks. I was using the recommended driver (Generic Z-Wave Outlet) and seemed to have the issue using this. Interestingly, a recent SW release how had a Generic Z-Wave Plus Outlet driver. As this is a Z-Wave Plus device, I tried that, but the response performance was considerably worse with this driver.

I've also seen about 3 updates in the past couple of days, so it seems like there may be issues getting addressed as well. And it looks like Generic Drivers are being updated.

Any ideas on a more appropriate driver for this outlet?

Cheers.

This sounds like a hardware issue if the physical button is failing

Unplugging and re-plugging resets so that the switch works and activating from the Dashboard works as well. Basically, this seems to un-wedge the outlet.

With the latest of a series of SW updates (2.2.123, which mentioned Generic Driver updates), the Generic Z-Wave Outlet Driver has worked properly through two cycles thus far, so I'm cautiously optimistic.

Cheers.

Download the Hubitat app