Issues with Kasa, trying to migrate to built-in app

Kasa integration worked great from 2019 until recently, using Dave's script back in the day.

Recently I noticed some things were not controlled as expected so I checked the logs and found a lot of errors with the Kasa devices (20 are installed). The orange warnings below are all Kasa devices using Dave's 2019 driver.

I have 20 devices driven by automations, so I was trying to save time by switching to the built-in Kasa app since it has a 'Migrate Kasa devices to built-in app'. However, Trying to do so gives a 'Kasa user app type not found' error as shown below. Does anybody know what this error means?

Thanks if any ideas!

For reference, the installed Kasa devices (using Dave's 2019 driver) currently look as shown below:

I recommend immediately RESTORING to a backup from before you updated to the built-in app. This will return w/o issues.

The only other current alternative is to delete the devices with issues and reinstalling. Remember to set up Static IP addresses for the devices.

2 Likes

Thanks 1e6 for the reply. I'll restore as you suggested and take in the sights before doing anything else. It seems like deleting/reinstalling is probably the right way to go.

Thanks again for thinking about it. Hubitat is cool and fun, I have around 130 devices going on it these days and is it awesome; so is the community :slight_smile:

Cheers.

(edit a bit later)

Restoring to a few days ago worked without issue. As a quick editorial, Hubitat takes some heat in the press for the funky interface, but the solid backend is what matters. In my view it is by far the best platform out there, and I hope it dominates the field in 5-10 years for that reason.

Here's a question, since I am running your code. I have a 2019 version of your Kasa integration running. I suspect other updates to hubitat messed it up, but I have no idea as that is just a voodoo feeling at best.

If I find your latest version of Kasa and paste it on top of the installed custom app code that defines the Kasa integration, would that just 'make it work' with the 20 Kasa devices and rule machines I have set up for them?

I realize time isn't free, DM me your paypal email address and I'll happily send you $20 for your reply.

No paypal. Acts of kindness or charitable contributions to you favorite charity are my payment.

As far as going forward from 4.x to the current - a lot of change. It may work - but I feel strongly you will see issues due to structural changes. I would reinstall.

But, if it is working now, why fix it?

1 Like

Download the Hubitat app