Issue with Leviton DZS15 switch

Hi all -

Brand new Hubitat user here. Previous Wink user. I removed all my devices from my Wink and have been adding them to the Hubitat. The first two Leviton switches (rockers) worked fine, and I've also paired two smart bulbs. However, my older DZS15 (not rocker) switch will not pair.

I tried waiting many hours, putting it back on the Wink and then specifically excluding it, and factory resetting it. Still no luck. It works fine on the Wink, but when I search for it in Hubitat, it simply won't find it (I've done the Z-wave search a bunch of times over the course of many hours).

Any idea ?

I only have one Leviton ... mine is a DZ15S and I didn’t have any issues getting it to join but it was not responding to commands even though it was supposed to be z-wave plus.

I contacted Leviton support, which wasn’t the easiest to find the right contact info I remember, and after some back and forth the said there was new FW and shipped me a replacement. Maybe something you could try.

1 Like

Problem solved ! Thanks to other threads here, I moved the hub much closer to the door, did a factory reset, and everything now works !

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.