Is this many indirect Z-wave connections normal?

Hi all, I'm wondering if anyone can analyze my z-wave mesh. I seem to have many more indirect connections than most. I do have a little bit of instability, with some devices not responding when they should - usually when in a Group device. But I just wanted to check and see if this looks out of whack at all. I did find one non-responsive device, and managed to remove it with a usbz stick. Everything is 700 series, or Plus. No non-plus. I found it odd that a lot of my 700 devices are only communicating at 40kbps. Thanks in advance.

Can you post your z-wave details page? (I know you posted from the hubitat z-wave mesh details app)

Sure - just thought the mesh details would provide more insight.

Hey there, you should try and get those S0 devices joined as no security. I had some issue with one of mine bogging down the network. Also, you should have a look at the number of repeaters you have vs. battery devices. I see quite a lot of sleepy end devices which could attribute to all the red in your table. You can filter these out with the Zwave tool to get a better idea.


Thanks @chad.andrews - two of those s0 devices are old monoprice motion sensors, so I doubt I'd be able to join them without the security. They're antiquated anyway, so I should replace them probably.

The "Fibarowl" is a Fibaro motion sensor installed in a hollowed out fake owl's eye socket. Kind of a fun project, and I used it to turn on some decorative lights and freak people out. BUT the sensor has begun falling apart and actually ran out of battery months ago, so I might retire the whole art project if it's bogging me down.

The last s0 is my GoControl garage door, which is literally being replaced with a MyQ motor next week, so I can go ahead and remove that one.

I have a lot of repeaters, but none that are dedicated repeaters. They're all outlets and switches. I have read that folks have had good luck using dedicated repeaters instead of relying on mains stuff that does it as an afterthought. So maybe that will help.

Thanks again

No problem, Your mains are actually great repeaters, but you should really have a look at your topology map, quite a bit of red there with little repeating. It could be actual geography or just some bad devices combined with end devices, either way it looks like it needs some work. I don't consider mine the best but 23 out of 27 devices are running at 100 kbps. The key is to have as many neighbors as possible, more so repeating neighbors to build a strong mesh.

What would be the first solution here, aside from adding more repeaters? Or is that pretty much the only thing to do?

Not necessarily the case, get rid of your known trouble devices first, change the S0 ones to no Security and then let it settle for a couple days to see if it improves or starts using new routes. If then things aren't improving, maybe try and move some outlets around or yes, maybe a couple repeaters (or just plug in outlets)

1 Like

I know this isn't a thread about S0 per se, but I got the same advice of eliminating as much S0 as possible from others on this forum. Do you have a Zstick? The way I got the Fibaro devices to pair without S0 was to use PC Controller+Zstick, disable S0 (and S2) in PC Controller, and associate the Fibaros that way. Then I'd go to the Hubitat Zwave settings and do a "Discover" on the device (waking it up right before doing so). This worked pretty consistently for me, maybe useful for you or others.

1 Like

I have a SilLabs USB-Z stick... I think I could use that, if it's going through PC Controller, right?




I've used the Aeotec Zstick Gen 5+, Aeotec Zstick 7, and the SiLabs UZB-7 (or whatever it is called, I forget).

For me, they all worked identically from PC Controller's point of view. Install Simplicity Studio from SILabs' website if you don't already have it. You need to add the Zstick as a secondary controller in Hubitat so you can use PC Controller to add/remove nodes, etc. I click the shield in the top-right an unclick all 4 security options.

I typically do my thing and then exclude the Zstick when I'm done with it so things don't keep trying to talk to and route through it. If I leave it in the Zwave mesh for a bit (let's say I'm updating firmware which takes me a couple of days) I just make sure to leave the laptop plugged in and powered on until I finish and eventually remove it.

1 Like

I :heart: Fibarowl!

1 Like

In case anyone was wondering :grin:


Hahahah, now that's pretty cool.

I have that exact same owl to try and shoo birds from my pool area.

BUT... Since barn owls like that aren't native to South Texas, the birds could care less and even on the 1st day were completely unimpressed by it. In fact, on day 1 a sparrow landed on its head and camped out for a while. :frowning:

1 Like

In the toplogy, it appears that 0x29 has no connections to other devices. Is this device functioning?

Good eye - last report was 7/28. Refresh says in log "The smoke and CO statuses have been cleared and the battery level will be refreshed the next time the device wakes up." Not sure how to wake up a smoke detector.

Here's a way!



1 Like

That'd wake up the whole neighborhood!

1 Like

For the First Alert Detectors, open and close the battery tray is what I do.

Download the Hubitat app