Is the 2nd Hub Registered on My Account?

I have several issues (do not have the option to select notification devices when setting up notifications and the hub just sits there when checking for updates) on the 2nd hub. However, I can select options to add services like remote access which connects to the web page which shows internet connectivity.

I have absolutely no issues on the 1st hub.

From the outside network I can select the dashboard of either hub. I believe this shows I have connectivity to either hub. I see a message on the 2nd hub indicating "Cloud connection is unavailable" leaving me to believe update services, and other external services like notification services are impacted by the 2nd hub not being connected.

When looking at my account only the first hub is registered.

1st question. When having 2 hubs does the 2nd hub that was connected to the configuration need to be connected?

2nd question. If yes to the 1st question, how should I go about correcting this.

Over the last two weeks I have converted from Insteaon and have stood up 33 devices (switches, dimmers, motion sensors, leak sensors, and Sengled bulbs. I have to say Hubitat ROCKS!!!

Thanks,
Don

1 Like

Welcome Don, your in good hands, plenty of people willing to help you out here. And if we can't HE support can....

Tagging @support.

Yup - and sounds like your second hub is not registered. I've tagged support for you.

In the meanwhile, from the FAQ:

1 Like

If the hub is unable to connect to the cloud, you cannot use remote access services via dashboard or mobile app.

Regarding your questions:

1st: your 2nd hub must also be connected independently in order to use cloud services. It appears that your hub has not been connected since May 1st. If the hub has unrestricted access to the internet, and for some reason is unable to connect, rebooting the hub from Settings may help to get the hub reconnected.

2nd: make sure the your network isn't preventing the hub to access the internet, and once confirmed, go to Settings then select "Reboot Hub".

NOTE if the hub was unplugged for any amount of time, its internal clock may drift and that could cause the hub not to be able to connect to the cloud. It would also cause the hub to disappear from my.hubitat.com, even if it has been registered. To correct this problem, go to Settings, then select Hub Details and then click on "Update from browser" button.

1 Like

Thanks everyone. Glad to be a part of such a great community! I am able to connect to the hub dashboard on my mobile device but did not see an option to select Register Hub. Hopefully support can help me out as well. I have some screenshots but don't see a way to attach them here.

Still learning my way around.
Don

1 Like

To validate that your hub is registered, go to Settings, then click Hub Details. Scroll to the bottom of the page and if you see an email listed in Emails Linked to this Hub, it means that your hub is registered. See my previous post if your 2nd hub isn't listed on my.hubitat.com.

Sorry, didn't see response from support in my haste to thank everyone.

I have rebooted the hub several times.

Onced initialized, the hub was never unplugged for any period other than reboots or power cycles.

I did select the "Update from browser" several times and it does show the correct time.

My email is linked to the hub as well.

That's good and bad. It's good because nothing on the hub side that I can think of, may prevent the hub to access the internet.

The bad, is that something within your local network may be preventing the hub to access the cloud. You could rule out that is a network issue by shutting down both hubs, then move the 2nd hub to the location of the first hub, which we know is able to connect to the cloud. If the 2nd hub is able to connect from the location of the 1st hub, then we know that something else within your local network is blocking its access.

@user837

Do you have any firewalls on your local LAN? If so, whitelist the MAC and IP address of the second hub.

3 Likes

Press the reset button on the bottom of the hub with a paper clip. This will reset your hub network settings. It may get you on.

Right because it's updating from YOUR browser not the NTP server it uses.

Definitely sounds like a local network issue. Does your router for any reason need to authorize devices connected to it? What equipment are you using to connect to the internet?

I am using a CISCO RV345P Firewall but have turn that off for trying to get this to work. It is connected to a comcast gateway.

It does have MAC address authentication filtering turned on but the mac address is in the list the an IP reservation set for the device. The assigned IP in the firewall is being assigned to HUB 2.

Everytime I look at the time it is correct without me updated it by pressing the button.

If I use the paper clip will it reset the device to the defaults and erase all the settings?

Just the network settings

2 Likes

I don't think that resetting the hub's networking settings will resolve the cloud connectivity. If you had issues with your hub communicating with your router, you wouldn't be able to access the hub. Resetting the networking settings doesn't erase all the settings, only affects the network communication.

1 Like

Problem Solved...I hope

After me trying your great ideas I decided to go "radical" and eliminate my infrastructure all together. Although I had connectivity to the HUB 2 from the inside and the time was consistently correct, I could also telnet to it from another subnet making me believe I could cross the firewall.

So...I changed Hub #2 back to DHCP and connected it directly on the Comcast gateway. This eliminated my Cisco RV345P firewall and Cisco 3750G Fiber switch.

My hopes was that whatever my network was doing to stop the registration process would not occur on my carrier's gateway and after registration I could move it back to my internal network.

Sure enough it first registered to the external IP address of the Comcast Gateway (saw this on my.hubbit.com).

I then moved it back to my inside network and set it back to DHCP reserved IP. I checked my.hubbit.com and it now shows registered to my internal IP address.

Hopefully I can put this behind me and get back to this great tool! I can't thank support and everyone on this forum enough for their fast and helpful suggestions.

Do I need to close this thread or something?

Thanks everyone,
Don

2 Likes

Thanks for the update. Glad you were able to reconnect the hub. Consider it done! :slight_smile:

Download the Hubitat app