Iris vs 1 keyfob

Iris vs1 keyfob.
This pairs easily now. Thank you Hubitat team. I am having trouble getting it to disable my alarm. I want to use it as a push button to disable. I have it set with in hsm ( under configure arming/ disarming/ cancel options) as a push button to disable alarm It doesn’t work but again I don’t know what button number should be ( within the hsm setting) or what the push and release number should be within the device page. Has anyone been successful in getting this to work?

You can easily see what button does what by opening a live logging window whilst pushing the buttons, or view them in the driver details page.

Awesome. Thanks. That told me what button to assign but it still doesn’t work. I have number 2 for press and release within device page I have keyfob listed to disarm, within hsm, and a 2 listed as button number Under live logging it shows it is reporting battery every 20 min. So it’s communicating. I am having a very similar issue with my iris keypad vs 2. I will post it separately


I had sent this in as a support email, but I am having the same issue. I am not a programmer and I don’t know if this matters, but on the device page, my button pushes register as “pressed” not “pushed”.

In the RM, is it looking for “pushed” and it is seeing “pressed”?

Yeah, this is on me, aparently I need to spend more time reading our own documentation...


I have tried 3 different programs. Mode manager, button app and rule machine and each one is specific in that it looks like it would work. But it doesn’t.

Pushed is broken, it'll be fixed in the next build.

Thanks Mike.
Thanks again for getting the Iris v1 devices working.
Still got fingers crossed on the v1 keypad.

1 Like

Thank you

Edit: This issue has been fixed so the workaround of using Released is no longer needed.

I found that on a V1 keyfob, pushed does not work, but released can be used to trigger my light switches. I used one side to turn all switches (includes smart outlets connected to lights) on and the other side to turn them all off. It isn't exactly how I had expected it to work, but it does.

Now for the other issue.
HSM arming/disarming/partial.
The 4-button V2 Smart Fobs work great for this. However, with the V1 fobs only having two buttons, how does one integrate them into the arming/disarming?
Right now, the V2 buttons are set up this way:
Circle=button 4
Diamond=button 3
Square=button 2
Hexagon=button 1
The V1 buttons are set up this way:
Person outside house=button 1
Person inside house=button 2

On the Iris app, I had them set up this way:
Circle (4)=Arm Away
Diamond (3)=Disarm
Square (2)=Partial
Hexagon (1)=not used

I have this set up the same way in Hubitat. Because I am used to this layout, I would prefer to keep it. The problem is that I don't know how to let the HSM app know that a V1 button 2 press/release should be used for Arm and V1 button 1 press/release should be used for disarm.

I might just use a V1 fob as a presence detector and use the buttons to turn on/off switches as I mentioned above. I don't think my wife uses the buttons anyway. She prefers the V1 fob to the V2 Smart Fob. My other alternative is to try to change my use of the V2 Smart Fob to have 1 and 2 as arm away and disarm. Then both would work. It would increase my probability of hitting the wrong button until I learn the new orientation though.

Edit: Release is the only option that works for the lights. Push, Hold, or Double-Tap does not work for the V1 keyfob.

I can’t get v1 fob to work with arm/ disarm. I think mike knows it’s an issue. I just tried using “released” but it doesn’t need work either. I have use 3 different apps

Is this so?

Edit: With the changes, the V1 keyfob no longer is limited to "Use released." That part of my comments below has been rendered moot. The presence detector part is still valid.

I finally got the V1 keyfob to work this way:

First, in the device manager pages, verify that the keyfob is properly connected to the hub. You should be able to see the number in the status change when you hit the buttons.

In the Button Controller ap, set up the keyfob with a name. Select the V1 keyfob as the device.
Under that, there is a slider for "Use released?" Select that to make it active (blue). Then go down and on the first line above actions, enter "1" and tab off to activate the menu underneath.
Go down to "Select actions when (name of your keyfob) button released."
Select "Set mode, tone."
For this button, 1 is the person outside the home is button 1. Select the option set the mode to "Away."
Complete the dialog with the done button for the dialog boxes to get you back to the page where you can enter "2" (person inside the house) on the next line.
Similar to above, change the mode for this one to "Home" and complete the dialog boxes with "done."

If all goes well, it should now arm the Hubitat for Away and Disarm it for Home when the appropriate button is pressed. If you have an Iris V2 keypad, you can also select an option to have the keypad beep when it registers a button press. That can be helpful to know if the button presses are actually registering without having to view a computer or phone screen.

While you are at it, you can use the "Mode Manager" app to set up "Away" and "Home" modes based on presence. Make sure the device has a timeout specified for Presence in the Preferences. Then you can configure the HSM to arm and disarm based on mode change (which the presence settings will do. Then you don't really even need to worry about buttons. Arming and disarming will be automatic. :smiley:

They just released an update that fixes the keyfob issue. I use button app and now it works


Okay. I'll have to test and see if I can change the settings on that keyfob from release to press and test to see if it works that way.

Edit: Tested and button push now works to arm/disarm. The keyfob no longer needs to be set for "Use released?" to work. Thanks for fixing this.

1 Like