Iris V2 (3405-L) Keypad losing volume

Hi all, I have 2 IRIS keypads paired with Hubitat. I noticed that after I paired the first one, the keypad wouldnt beep when the keys were pressed. Instead, it made a very faint "tick tick tick tick" sound. Also, the siren would not make any noise when triggered from Hubitat Safety manager.

The second one worked fine. However, once I clicked on "Beep" from the device configuration page on the working one - all of a sudden it too lost the siren and the beeps on keypress.

Is something wrong with the driver, or is there a way to reverse this? I've tried factory resetting them a few times to no avail.

To turn up the volume press and Hold 2 on the keypad and it should get louder, release at desired volume. Same procedure but 5 to lower the volume.

Also welcome to the Hubitat Community.

Hi Brandon, I tried that and it worked temporarily. What actually ended up fixing it for me was installing this wonderful app. This pretty much restored my iris stuff to its former glory.


I am surprised that you only got temporary volume from the keypad as I have 5 of these and they always are beeping at night to let me know the system is arming and beep on key presses for me. I never owned an Iris System, just used the keypads so it is possible different firmware may come in to play. Regardless glad you found something that works for your needs.

When using Hubitat's keypad drivers with my Xfinity/Centralite 3400, two Iris V2s, and an Iris V3 keypad, none of them sound key presses, however they do sound entry, exit, panic, arm and disarm.

I've seen other reports this issue, and my total dislike of the silent key press is why with Mitch Pond's assistance, I ported his ST keypad driver used with SHM Delay, from Smartthings to Hubitat. I wanted to make the driver work directly with HSM, however that was not possible.

I agree, it is likely a firmware issue since it works with your devices.

I hesitated testing mine to confirm it retains the beeps on keypress as mine have always been fine. I went ahead and pressed beep in the driver and confirmed that both pressing the siren and pressing keys on the keypad still function as expected. I also pressed configure and verified it worked as well. As I am writing this my Alarm is auto arming and did the countdown beep and what I consider the armed confirmation beep. Not sure the official terminology.

This leads me to believe firmware is the difference, but wanted to test to make sure it wasn't a HE version type issue. I am on

We are both using the same HE version. I am unable to find the keypad's firmware version.

Currently firmware versions are not displayed in Hubitat for most devices.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.