Iris V1 Fob

I'm using one of these for presence/geofencing and it was working for a while but now it is not seen by my hub unless it is in the house. Even then the system will cycle between home and away at times, therefore setting the alarm off. It worked fine with the Iris system and worked pretty well at first with HE. Any thoughts?

I'm guessing you've tried replacing the battery regardless of what % it shows remaining?

+1 on the battery change suggestion.

This happened to me as well for a while.

If you've already changed the battery, and it hasn't made a difference, then,
Change the "presence timeout", the the preferences of the device to 5 minutes.
That settled it down for me.

I've been going through CR2450's like they were going out of style. I finally got smarter and purchased some rechargeable s + a charger. A great investment.
(Sorry, I realized that this applies to the V2, not V1 version of this device. My apologies.)

The Iris V1 fob uses a CR2 battery, not a CR2450.

I have this fob (Iris 2 button) brand new (old stock) and it won’t pair. Lights are blinking (seeking a hub, I presume) and Hubitat said it found a device and is “initializing…” but no device was created. Tried again but now it doesn’t see a new device. Seems like I’m semi-connected. Any ideas?

@Otto_Mation maybe you can help?

Tagging @scunny too.


How are you trying to pair this? As Zigbee or Iris V1 Zigbee?

Yes. :wink: Tried both ways 4x each. Also tried by selecting by type/brand.

About the only thing that I can suggest it that you reset the fob and make sure that you pair it as an Iris V1 device. I am not using those fobs on my current system but I know that @Scunny has on his. I will be talking to him in the next day or so and will ask him to chime in. Let me know if you do not have the reset procedure and I will dig around to see if I can find it for you.

ETA: Also make sure that you do not have any unknown devices paired on your system. If you do, delete them and try again.

ETA2: Reset procedure. Iris 1st Generation Key Fob Reset - YouTube

Rebooted the hub and tried again as Iris V1. It said initializing again, timed out, then after a while popped up with the name prompt. Odd but it worked.

1 Like

Also moved to within a few feet of the hub, vs about 20 feet. Not sure it made any difference, but just for the record.

I have a couple of these paired to my hub. Like @Otto_Mation mentioned you need to factory reset the fob and pair it as an Iris V1 device. The initialization can take a few minutes and having the device next to the hub will help.

Edit: A fresh battery may help as well.

1 Like